PDA

View Full Version : fmencoder error 127



basnyd
15-May-2006, 03:34 PM
Hi -

When I try to run the form with the encoder, I get the following emailed back to me:

The following error occurred in FormMail :
filter_failed
**********
Error=Filter "encode" failed (status 127):


(User data suppressed for security purposes. )

The form was working fine before I tried implementing the encoding stuff.

I ran http://yoursite/cgi-bin/fmencoder and got:

GET method not yet implemented

Which looks to be a good thing based on another post I'm reading regarding the same issue.

My filters line looks like this:

$FILTERS = array("encode"=>"$REAL_DOCUMENT_ROOT/cgi-bin/fmencoder -kpubkey.txt",
"null"=>"null");

My key file is in the cgi-bin directory along with the fmencoder file.

What else should I be looking at?
Thanks,
Barb

basnyd
15-May-2006, 07:26 PM
I ran phpinfo and got the following:

SITE ROOT = /home/virtual/site262/fst

SITE HTMLROOT = /home/virtual/site262/fst/var/www/html

SITE CGIROOT = /home/virtual/site262/fst/var/www/cgi-bin

DOCUMENT ROOT = /home/virtual/site262/fst/var/www/html

basnyd
15-May-2006, 07:36 PM
I changed the filter line to:

$FILTERS = array("encode"=>"/home/virtual/site262/fst/var/www/cgi-bin/fmencoder -kpubkey.txt",
"null"=>"null");

Nothing changed. When I submitted the form. I saw the error page that says "One or more fields are incorrect:" But it does not list any incorrect fields. All the required fields are listed.



I'm still emailed this error:



The following error occurred in FormMail :
filter_failed
**********
Error=Filter "encode" failed (status 127):


(User data suppressed for security purposes. )

Any suggestions? I did not have this problem on another client site that I did previously, but that was also with a different hosting company.
Thanks,
Barb




.

basnyd
17-May-2006, 07:05 PM
I'm stil having the same issue.

I've tried the following:

Ran the alert and got -
REAL_DOCUMENT_ROOT: /home/virtual/site262/fst/var/www
Modified line 2826 to be -

$SET_REAL_DOCUMENT_ROOT = "/home/virtual/site262/fst/var/www";
Line 3507 is -

$FILTERS = array("encode"=>"$REAL_DOCUMENT_ROOT/cgi-bin/fmencoder -kpubkey.txt",
"null"=>"null");
The email script error I'm sent is -

The following error occurred in FormMail :
filter_failed
**********
Error=Filter "encode" failed (status 127):

(User data suppressed for security purposes. )
When I submit the form (even with all required fields completed) I see my error template page with the following text. There are no field names listed. -

One or more fields are incorrect:

Any suggestions? I'm at my wits end. Here is a link to the form - http://www.sohotel-ny.com/formNEW.htm

russellr
18-May-2006, 11:35 PM
Hi,

I think I'm going to need access to the server to run some tests to sort out the problem.

You can send access details to me using this secure form:
https://secure.rootsoftware.com/~tectite/sendsecret.php

I'm on vacation at the moment, so I'm only checking my email a couple of times a day.

russellr
20-May-2006, 12:54 AM
Hi,

Bad news. :(

There's something seriously wrong with PHP on this server.

I spent over an hour trying to get basic things to work.

You can see the script I created called "rr.php".

I'm sorry I can't overcome broken PHP installations.

russellr
20-May-2006, 06:28 AM
Hi,

Good News! :)

I had a bit of think about it and used the httpencode feature as a workaround.

It works.

So, formNEW.htm now works with formnewmail.php. formnewmail.php has had its SOCKET_FILTERS configured.

formNEW.htm specifies filter "httpencode".

All seems to work.

However, I'm still convinced there are faults with the PHP installation that are stopping normal filter operation.

basnyd
20-May-2006, 11:53 PM
Hi Russell,

Thank you for all of your work on this. I appreciate it. If all of the required fields are filled in I do receive the reservation. I saw 2 tests from you.

There still seems to be an error when a required field is not filled in properly. I see the error page, but it does not tell me what field was not filled in properly. I then receive an email with the following error message:

The following error occurred in FormMail :
filter_failed
**********
Error=Filter "httpencode" failed (missing __OK__ line): <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /cgi-bin/fmencoder
on this server.</p>
<hr>
<address>Apache Server at www.sohotel-ny.com (http://www.sohotel-ny.com/) Port 80</address>
</body></html>

(User data suppressed for security purposes. )

Can you tell me more specificially about what may not be setup properly on the php side of things? Could it be a rights issue? I'm happy to talk to the hosting company. I just need to know what I should be asking for.

Again, thanks for all your help.
Barb

russellr
21-May-2006, 12:11 AM
Hi,

That's strange. If you are getting that error and receiving the correct email, it makes no sense.

If you are getting that error just because a field isn't filled in correctly, that also makes no sense.

That error indicates there's a permission problem for the web server accessing that page (fmencoder). It shouldn't work sometimes and not others. It either works or doesn't.

First, determine what the real situation is. Does it work:

every time
sometimes
neverIs the error always the same? If it's always the "Forbidden" message (which I didn't see during my tests) then that's a permissions problem in the Apache setup or .htaccess file (or a server/PHP fault).

basnyd
21-May-2006, 12:25 AM
The form works EVERY time that ALL required fields are completed.

The form fails EVERY time a required field is missing. Everytime the form is submitted with a blank required field I receive the same email message:

To: webmaster@sohotel-ny.com
From: FormMail@www.sohotel-ny.com

The following error occurred in FormMail :
filter_failed
**********
Error=Filter "httpencode" failed (missing __OK__ line): <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /cgi-bin/fmencoder
on this server.</p>
<hr>
<address>Apache Server at www.sohotel-ny.com (http://www.sohotel-ny.com) Port 80</address>
</body></html>

(User data suppressed for security purposes. )

If you skip a required field and press the submit button what do you see on the screen? Does it tell you what field was not filled in? This is what I see on the screen. Before I did the encode, I would see a list of field names for the required fields on the form that were blank.

One or more fields are incorrect:





( Please press the browser's back button to return to the reservation page to correct the error)

basnyd
21-May-2006, 02:02 PM
I'm doing some more digging. I'm comparing the php setup on the server that works and on the server that doesn't work. I found a couple differences (listed below), would any of these cause a problem?

allow_call_time_pass_reference - OFF on server not working (Local & Master); ON with the other host where encoder works.

safe_mode - Local = ON, Master = OFF on server not working; Local = OFF, Master = OFF on server not working.

I was comparing values from your script rr.php to http://1-800gadgets.com/phpinfo.php (where encode works).

basnyd
21-May-2006, 05:25 PM
It looks like PHP Zend Optimizer is not installed. Is this required for the FormMailEncoder/Decoder? The host says I need to upgrade to a VPS in order to get Zend Optimizer installed on the server. Is there a work around if Zend Optimizer is not there?

Thanks,
Barb

russellr
21-May-2006, 10:43 PM
Hi,



safe_mode - Local = ON


I suspect that is causing some problems. If you can arrange to switch it off, it may make PHP behave more consistently.

I think FormMail is trying to send you an alert about the user's error. Because you've specified a filter, it will filter the alert message. That's why it's calling the filter. But why would it get a "Forbidden" error from Apache? That makes no sense. I'm thinking - why would the filter work sometimes and not others?

Try setting ALERT_ON_USER_ERROR to false - that should skip this particular problem.

basnyd
22-May-2006, 05:08 PM
It works!!! I had the host turn off the "safe mode". I also then set ALERT_ON_USER_ERROR to false. The empty required fields now show up on the error page. All reservations are encrypted!!! And I don't receive any more error messages.

Thank you for all your help. I really appreciate it. :D
Barb

russellr
23-May-2006, 12:56 AM
Hi,

Good news. :D