View Full Version : Using the "sslencode" filter for executing fmencoder on another server

25-Apr-2007, 04:47 PM
I've successfully installed fmencoder on a separate FreeBSD server. When I try to open it directly in the browser, it returns the expected message:

GET method not yet implemented

Since it seems to be working on the non-Windows server (we're still trying to
get the encoder to work on our Windows IIS Server), I was hoping to use
the "sslencode" filter described in the FormMail documentation to execute the
remote encoder. The idea is to still host the form on our main Windows
server and still be able to encrypt the form output.

Would you please send instructions on how to use the "sslencode" filter?
Thank you.

25-Apr-2007, 08:36 PM
Never mind.

After pulling my hair out for a few days, we finally got formencoder to work on 2003 Windows IIS 6.0 (using PHP 5.2.1). Our server administrator did a great job setting up a cgi-bin for executables and setting proper permissions.

Looks like the $SOCKET_FILTERS paths needed to be set properly (absolute paths with back slashes instead of forward slashes - $REAL_DOCUMENT_ROOT caused errors) and we had to use "httpencode" instead of the normal "encode" filter.


25-Apr-2007, 08:56 PM

Glad to hear it's all working.

absolute paths with back slashes instead of forward slashes - $REAL_DOCUMENT_ROOT caused errors

This is new. Perhaps it's something new in PHP 5. In PHP 4, forward slashes worked on Windows because PHP did the translation internally.

This might mean that you can now get the $FILTERS setting working and not use $SOCKET_FILTERS. It's worth a quick try because it's a significantly faster method.

Make sure you use Windows \\ instead of /, of course.

If you do need to use $SOCKET_FILTERS, you don't need to use sslencode to get an encrypted connection to fmencoder because your server is contacting itself. The "network" traffic never leaves the server so there's no security issue. The communciations is purely within the server.