PDA

View Full Version : FMEncoder failed - status 1



jake
27-Jul-2009, 06:50 PM
Hello,
First I got the form working, then installed the encoder onto the Linux server as the instructions explained. Now the following error appears:

The following error occurred in FormMail :
filter_failed
*****Content-type: text/plain

Input failed after 419 bytes
*****
Error=Filter "encode" failed (status 1):

I'm guessing the error message is that it failed after 419 bytes, what does that mean?

Thanks in advance

russellr
27-Jul-2009, 08:05 PM
Hi,

This message can only happen if you're trying to access FormMailEncoder via a web POST.

So, are you setting up $FILTERS or $SOCKET_FILTERS?

If $FILTERS, then this must be a file system path not a URL. So, the path must *not* begin with "http://". Check the Help section again for instructions for setting this up.

Please let me know if you need further assistance on this.

If $SOCKET_FILTERS, then let me know and I'll advise from there.

jake
27-Jul-2009, 08:14 PM
Hi Russell,
I did use the system paths, here is what I have in formmail.php for $FILTERS:

$FILTERS = array("encode"=>"/home4/greenma8/public_html/cgi-bin/fmencoder ľk/home4/greenma8/public_html/cgi-bin/pubkey.txt",
"null"=>"null",
"csv"=>"csv");

I tried it without the "null" and "csv" lines, and produced the same error.

russellr
27-Jul-2009, 08:43 PM
Hi,

null and csv are different filters and don't affect each other or the encode filter.

OK, so the message you're getting makes no sense.

I'll have to investigate for you.

Please send server access details using this secure form:

https://secure.rootsoftware.com/~tectite/sendsecret.php (https://secure.rootsoftware.com/%7Etectite/sendsecret.php)

Please include the URL to your HTML form so I have the full picture.