PDA

View Full Version : Encoder error message



lal
18-May-2005, 10:27 AM
Hi
having trouble with encoder on a secure site (though has worked fine on a non-secure site I first tried it on).

Can't use standard encode - got this when I did:

The following error occurred in FormMail [M18]:
chdir_filter
**********
Error=Cannot chdir to "/home/.sites/111/site30/cgi-bin" to run filter "encode": SAFE MODE Restriction in effect. The script whose uid is 557 is not allowed to access /home/.sites/111/site30/cgi-bin owned by uid 99 [M59]

So, using httpencode filter, put formmail.php into debug mode and got:

Warning: Unable to access language.inc in /home/.sites/111/site30/web/formmail.php on line 1124

Warning: Failed opening 'language.inc' for inclusion (include_path='') in /home/.sites/111/site30/web/formmail.php on line 1124

Warning: Cannot send session cache limiter - headers already sent (output started at /home/.sites/111/site30/web/formmail.php:1124) in /home/.sites/111/site30/web/formmail.php on line 2219

Warning: Cannot set time limit in safe mode in /home/.sites/111/site30/web/formmail.php on line 5855

Warning: Wrong parameter count for fgets() in /home/.sites/111/site30/web/formmail.php on line 5917

Warning: Wrong parameter count for fgets() in /home/.sites/111/site30/web/formmail.php on line 5917

This last warning is repeated over and over, and over and over....

Any ideas?

Kind regards

Lal

russellr
18-May-2005, 11:09 AM
Hi,



So, using httpencode filter, put formmail.php into debug mode and got:

Warning: Unable to access language.inc in /home/.sites/111/site30/web/formmail.php on line 1124

Warning: Failed opening 'language.inc' for inclusion (include_path='') in /home/.sites/111/site30/web/formmail.php on line 1124


This warning can be ignored.



Warning: Cannot send session cache limiter - headers already sent (output started at /home/.sites/111/site30/web/formmail.php:1124) in /home/.sites/111/site30/web/formmail.php on line 2219

This is caused by the previous errors.



Warning: Cannot set time limit in safe mode in /home/.sites/111/site30/web/formmail.php on line 5855

Safe mode is painful, but you should be able to modify your file ownership or permissions to work around it. Your hosting provider should be able to advise you on this.



Warning: Wrong parameter count for fgets() in /home/.sites/111/site30/web/formmail.php on line 5917

Warning: Wrong parameter count for fgets() in /home/.sites/111/site30/web/formmail.php on line 5917

This suggests you have PHP version earlier than 4.2.0. Is that correct?

Your hosting provider really should upgrade to the latest PHP and stop using SAFE mode.

Apart from the above warnings, does the process actually work? Do you receive an encrypted form submission?

lal
18-May-2005, 11:26 AM
Wow! Speedy or what, is it not the middle of the night with you?

Have PHP version 4.0.6!!! And hosting co are adamant they will not update nor remove SAFE MODE can you believe?

Sadly the process doesn't actually work, just loops ad infinitum at the end.
Seems I may need to move hosting company unless you have any other ideas?

Many thanks for your help.

L

russellr
18-May-2005, 09:11 PM
Hi,


Have PHP version 4.0.6!!! And hosting co are adamant they will not update nor remove SAFE MODE can you believe?

If that's their attitude, I honestly think you should look for a better hosting company. Version 4.0.6 is extremely old.

However, if you don't want to move, then I may be able to sort out the problems with access to your server.

Let me know which way you want to proceed.

lal
19-May-2005, 08:15 AM
If you can sort it out I'd be delighted.
How do I give you access to the server?
I'd rather not post details here! No offence...

Kind regards

Lesley

russellr
19-May-2005, 08:29 AM
Hi,


I'd rather not post details here!
Very wise! :D

Here's the form to send us information securely:
https://secure.rootsoftware.com/~tectite/sendsecret.php

Please send your server name (domain name), SSH or FTP user name, and password, and the URL of the form you're trying to get to work.

lal
19-May-2005, 09:05 AM
will do,

many many thanks

L

lal
19-May-2005, 09:42 AM
Hi Russell,
getting a pile of emails from Formmail@secure.snuggyhoods.co.uk, shall I send them to you? Or do you want to mod the DEF_ALERT?

Kind regards

Lesley

russellr
19-May-2005, 11:35 AM
Hi,

Just delete them.

It was some initial testing.

I'll modify DEF_ALERT when I need to.