Results 1 to 10 of 10

Thread: Filter not found ?? installing fmencoder

  1. #1
    Join Date
    May 2006
    Posts
    5

    Default Filter not found ?? installing fmencoder

    I'm trying to install formmail encoder on this server (Win2003, IIS)
    and am getting this error using this form:
    http://www.sbs4money.com/sbs4/test.html
    and this formmail
    http://www.sbs4money.com/sbs4/formml2.txt (copy of the php file)

    > The following error occurred in FormMail :
    > filter_not_found
    > **********
    > Error=Cannot execute filter "encode" with command
    "C:/inetpub/wwwroot/sbs4money/cgi-bin/fmencoder -sbs4m.txt > C:\WINDOWS\TEMP\FMF356.tmp 2>&1": No error
    >
    >
    > (User data suppressed for security purposes. )


    Any ideas?

    -Ben Wright

    ps... phpinfo at
    http://www.sbs4money.com/sbs4/php.php
    Last edited by wrightb; 12-May-2006 at 03:02 AM.

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Filter not found ?? installing fmencoder

    Hi,

    For Windows, you want this:
    PHP Code:
    $FILTERS = array("encode"=>"C:\\inetpub\\wwwroot\\sbs4money\\cgi-bin\\fmencoder -ksbs4m.txt"
    or
    PHP Code:
    $FILTERS = array("encode"=>"C:/inetpub/wwwroot/sbs4money/cgi-bin/fmencoder -ksbs4m.txt"
    PHP automatically maps '/' to '\' on Windows boxes for file pathnames.

    Note also the "-ksbs4m.txt" - you were missing the "k".
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    May 2006
    Posts
    5

    Default Re: Filter not found ?? installing fmencoder

    thanks for the fast response, i fixed that, but im still getting this error

    i tried with and without a space between k and sbs4m


    The following error occurred in FormMail :
    filter_not_found
    **********
    Error=Cannot execute filter "encode" with command "C:\inetpub\wwwroot\sbs4money\cgi-bin\fmencoder -k sbs4m.txt > C:\WINDOWS\TEMP\FMF391.tmp 2>&1": No error


    (User data suppressed for security purposes. )

    everything is still in the same place and i updated formml2.txt

  4. #4
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Filter not found ?? installing fmencoder

    Hi,

    I just tried this URL:
    http://www.sbs4money.com/sbs4/cgi-bin/fmencoder.exe

    It works!

    So, one more change - add ".exe" to the command, like this:
    PHP Code:
    $FILTERS = array("encode"=>"C:\\inetpub\\wwwroot\\sbs4money\\cgi-bin\\fmencoder.exe -ksbs4m.txt"
    If that still doesn't work, then your path must be wrong (c:\inetpub\wwwroot....).
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  5. #5
    Join Date
    May 2006
    Posts
    5

    Default still no...

    Same error as before, just with .exe in the path now...

    The error emails go here if you'd like to do some probing:

    info@lqwa.org

    log into the email here
    http://mail.lqwa.org:9998/Login.aspx
    username: info@lqwa.org
    password: info All this account does is accept these errors (and some spam, of course)

    If you're still left scratching your head as much as I am, and if you think it could help, I can give you remote desktop access to the server.


    To: info@lqwa.org
    From: FormMail@www.sbs4money.com

    The following error occurred in FormMail :
    filter_not_found
    **********
    Error=Cannot execute filter "encode" with command "C:\inetpub\wwwroot\sbs4money\cgi-bin\fmencoder.exe -ksbs4m.txt > C:\WINDOWS\TEMP\FMF3D6.tmp 2>&1": No error


    (User data suppressed for security purposes. )

  6. #6
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Filter not found ?? installing fmencoder

    Hi,

    Does C:\Windows\Temp exist and can the webserver software create files in there?

    Are you absolutely sure you have the correct path to the program?

    Yes, I can look at it for you, but it won't be for a couple of days as I'll be travelling.

    If you have a hosting provider they should be able to give you the right values for paths etc.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  7. #7
    Join Date
    May 2006
    Posts
    5

    Default Re: Filter not found ?? installing fmencoder

    This server is not mine, but I have remote desktop control over it so i'm fairly sure I have the paths all right. The program works, as evidenced by the fact that you can browse to it and get that message "get method not implemented, etc".

    If you have no other ideas, PM or email me and Ill send you info to rd to the server to maybe see what is wrong.

    Thank you so much for all your help.
    -Ben Wright

  8. #8
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Filter not found ?? installing fmencoder

    Hi,

    Yes, it's quite strange.

    Please send me access details securely using this form:
    https://secure.rootsoftware.com/~tectite/sendsecret.php
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  9. #9
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Filter not found ?? installing fmencoder

    Hi,

    Did you get my email and have you tried uploading the right key file?
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  10. #10
    Join Date
    May 2006
    Posts
    5

    Default Re: Filter not found ?? installing fmencoder

    Yes, I uploaded the right key file and using httpencode it worked.

    Not sure why it didnt work the other way, but it works now.

    Thank you very much for your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fmencoder error
    By Chrisanna in forum FormMailEncoder/Decoder
    Replies: 22
    Last Post: 11-May-2005, 02:04 PM
  2. Error runing fmencoder
    By matty in forum FormMailEncoder/Decoder
    Replies: 20
    Last Post: 10-Dec-2004, 08:39 PM
  3. Re installing decoder
    By dunn123 in forum FormMailEncoder/Decoder
    Replies: 1
    Last Post: 29-Oct-2004, 08:59 PM
  4. The requested URL was not found on this server.
    By aussieincanada in forum FormMail Subscription Support
    Replies: 1
    Last Post: 27-May-2004, 07:46 AM
  5. filter name
    By crabtree in forum FormMailEncoder/Decoder
    Replies: 1
    Last Post: 07-May-2004, 11:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •