Results 1 to 2 of 2

Thread: "...not working correctly as there was no data found." never see this message before

  1. #1
    Join Date
    Dec 2011
    Posts
    9

    Question "...not working correctly as there was no data found." never see this message before

    Hi,
    I've used the very good php Tectite form mail more than once and it was ok. Just some little problems I've been able to fix.
    But now using it in a new website, after the submit I get this message from formmail.php:

    "This URL is a Form submission program.

    It appears the form is not working correctly as there was no data found.
    You're not supposed to browse to this URL; it should be accessed from a form."

    I don't understand what's wrong and I really don't know what to do.
    The testalert works perfectly.

    Have you please any idea ?
    Thanks


  2. #2
    Join Date
    Dec 2011
    Posts
    9

    Lightbulb Re: "...not working correctly as there was no data found." never see this message bef

    Hi,

    I fixed the problem: I change the path to php's file as "http://www.domain_name.com/path/to/myform.php" instead of "http://domain_name.com/path/to/myform.php" and now it's ok, I get my "good url" after submission.

    It's true I could think about it before, but I have to say the Hosting service where is the form's page is not so clear about root, real path and so on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Message stating "Unable to create check file"
    By mcrider in forum Community Support
    Replies: 2
    Last Post: 06-Oct-2010, 04:11 PM
  2. Set "good_url" value based on required form data
    By Brian Lehmer in forum Features Questions
    Replies: 2
    Last Post: 10-Nov-2009, 07:47 AM
  3. "insession specified, but no data found in session"
    By Jano13 in forum Community Support
    Replies: 0
    Last Post: 26-Oct-2009, 03:42 PM
  4. Replies: 1
    Last Post: 26-Dec-2008, 03:09 AM
  5. False Positive: The fields "zip" and "zip" contained duplicate data [M143]
    By BLynch in forum FormMail Subscription Support
    Replies: 2
    Last Post: 08-Aug-2007, 08:25 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •