Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: problem with return link and form data

  1. #1
    Join Date
    Feb 2007
    Posts
    82

    Default problem with return link and form data

    I have tried every single step in the fmbadhandler how to, but I cannot get the return link to work in my error page.
    I have been using the tectite.php for a while and the return link has never worked, but I hadn't taken the time to try to fix it because most of the time if the user presses 'back' the data will be there and they can resubmit, but the reason I am trying to get the return link to work now, is that I have noticed that when they go "back' to fix an incorrect or missing email address, the data that is being submitted is not refreshed and the 'missing or incorrect email address error' keeps getting displayed no matter how the address is corrected and filled in.
    Any ideas?

    form data:
    form enctype="multipart/form-data" method="post" action="techtiteform2.php" name="insonlineform"
    input type="hidden" name="env_report" value="REMOTE_HOST,REMOTE_ADDR,HTTP_USER_AGENT,AUTH_TYPE,REMOTE_USER"
    input type="hidden" name="required" value="realname:Name,email:EmailAddress,primaryphone:PrimaryTelephone,street:StreetAddress,city:City,zip,insurancecompanyname:InsuranceCompanyName,Complaint"
    input type="hidden" name="recipients" value="crd"
    input type="hidden" name="subject" value="Insurance Online Complaint Form"
    input type="hidden" name="bad_url" value="fmbadhandler.php"
    input type="hidden" name="this_form" value="http://www.nmprc.state.nm.us/insonlineform.htm"
    input type="hidden" name="bad_template" value="errors.htm"
    input type="hidden" name="good_template" value="feedbackins.htm"
    input type="hidden" name="mail_options" value="HTMLTemplate=ins1.htm,TemplateMissing=left blank"
    input type="hidden" name="derive_fields" value="DateTime = %'Date of form submission was: '% . %date% + %time%"
    tectite and fmbadhandler
    $TARGET_URLS = array("http://www.nmprc.state.nm.us/");
    Last edited by kdeguero; 02-Apr-2007 at 04:34 PM. Reason: form data did not appear

  2. #2
    Join Date
    Feb 2007
    Posts
    82

    Default Re: problem with return link and form data

    http://www.nmprc.state.nm.us/insonlineform.htm
    here is one of the forms I am trying to work on
    Last edited by kdeguero; 02-Apr-2007 at 04:43 PM. Reason: fix format

  3. #3
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: problem with return link and form data

    u got lots of broken javascript - that wont help.

    fix ur js

    also set PUT_DATA_IN_URL to false....its a big form and that could be causin probs

  4. #4
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: problem with return link and form data

    PS i wuz using IE 6 with debug on - so every stepped popped up a js message

  5. #5
    Join Date
    Feb 2007
    Posts
    82

    Default Re: problem with return link and form data

    I am using the whole yahoo library of js...and I don't know how to fix it, if something is wrong, well that is I would probably make it worse instead of fixing it.....but would love to learn, so I will go looking.
    How do you get debug turned on in IE?

  6. #6
    Join Date
    Feb 2007
    Posts
    82

    Default Re: problem with return link and form data

    the thing that concerned me, was that it only seems to be the email address field that it doesn't want to refresh,
    lets say if you purposefully leave off realname, and get the error page, and go back, and fix realname, the form will then post just fine, but when you do the same thing with email, it just keeps giving the error message, the form will not post unless you reload and refill it

  7. #7
    Join Date
    Feb 2007
    Posts
    82

    Default Re: problem with return link and form data

    well, I changed the value in the php, and tested it just as I said above and it helped...I don't have time to test any other scenarios, but it seems to have fixed, thank you much...I would still be interested in the debug option of IE...

  8. #8
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: problem with return link and form data

    its years since i got the debugger...i think it is called the Microsoft Script Debugger.

    a search found this: http://blogs.msdn.com/ie/archive/2004/10/26/247912.aspx

  9. #9
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: problem with return link and form data

    Quote Originally Posted by kdeguero
    the thing that concerned me, was that it only seems to be the email address field that it doesn't want to refresh,
    lets say if you purposefully leave off realname, and get the error page, and go back, and fix realname, the form will then post just fine, but when you do the same thing with email, it just keeps giving the error message, the form will not post unless you reload and refill it
    nup, it's email adn realname 'coz these are special fields.

    its a known annoyance.

    there are several posts about it around here and i think the how to guides meniton it too

    the fix is to rename these fields to something else, and then derive email and realname from these other fields

  10. #10
    Join Date
    Feb 2007
    Posts
    82

    Default Re: problem with return link and form data

    ok, thanks I will try that...and i will go check out the link as well, thanks so much for your help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Return All Variables To Form Page On Error
    By cornernote in forum FormMail Subscription Support
    Replies: 12
    Last Post: 31-Oct-2004, 09:20 PM
  2. Return All Variables To Bad_Form Page On Error
    By vladimir in forum FormMail Subscription Support
    Replies: 2
    Last Post: 07-Jun-2004, 05:13 PM
  3. No return link for badhandler
    By ptr in forum FormMail Subscription Support
    Replies: 3
    Last Post: 26-May-2004, 11:27 PM
  4. POST form data as well as email
    By zippy in forum FormMail Subscription Support
    Replies: 20
    Last Post: 24-Jan-2004, 04:29 PM
  5. not seeing form data
    By brownie in forum FormMail Subscription Support
    Replies: 6
    Last Post: 19-Jan-2004, 01:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •