Results 1 to 4 of 4

Thread: Problem with file Attachments

  1. #1
    Join Date
    Jun 2004
    Posts
    2

    Talking Problem with file Attachments

    Hi there,

    Firstly thanks for the brilliant formmail script - am loving it!!!

    Nextly, I have a file upload field in my form as follows:
    <input type="file" name="file" size="80" class="box" id="file">

    And I have included the appropriate form header as specified in the script instructions ie:
    <form method="POST" enctype="multipart/form-data" ...... etc>

    However when I do upload a file (eg a Word doc), it is attached to the resulting email as a .txt file which if I open it has the following beginning text:

    Content-Type: application/msword; name="guess what.doc"; charset=ISO-8859-1
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="guess what.doc"

    followed by gibberish.

    Where should I make adjustments?

    Please Help. Thank you!

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Question Re: Problem with file Attachments

    Hi,

    It looks like you've done everything right and the attachment has been made correctly.

    Could you please send a form result to me like this:
    1. Change FormMail's $TARGET_EMAIL to include this extra string: "^supportstaff_AT_tectite.com" (replacing _AT_ with @ or your AT_MANGLE setting).
    2. Change your form to include "supportstaff_AT_tectite.com" in your recipients field (again replacing _AT_ with @ or your AT_MANGLE setting).
    Do a form submission with a Word document attached.

    I'll have a look at the structure of the MIME email that's created and let you know what the problem is.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Aug 2005
    Posts
    6

    Default Re: Problem with file Attachments

    I am getting the exact same problem as lemonade describes. I am using v 6.02.

    Was an answer ever found for this?

    My email client is MS Outlook.

    I have used other formmail scripts to attach files to emails with no problem so I don't think this can be a server issue - but I could be wrong!

    I am currently trying out several formmail scripts. Although not too complicated this one doesn't appear to be the simplest to set up but seems well supported. A quick response to this post will hopefully confirm this.

    It would appear to have most of the features I would want. Also written in PHP means that I can have a go at minor changes myself if need be.

    Regards,

    Alan

  4. #4
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Problem with file Attachments

    Hi,

    It's hard to guess what's wrong without seeing the result.

    You can try setting BODY_LF to "\n" instead of "\r\n".

    If that doesn't work, following the instructions above to send a sample to me.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upload attachments
    By Mamut in forum FormMail Subscription Support
    Replies: 10
    Last Post: 20-Jan-2005, 07:21 AM
  2. Form attachments - encoding issue
    By mark70 in forum FormMail Subscription Support
    Replies: 5
    Last Post: 06-Oct-2004, 07:45 PM
  3. Weird attachments
    By Jacob in forum FormMail Subscription Support
    Replies: 4
    Last Post: 17-Sep-2004, 01:04 PM
  4. Problem with attachments
    By sigurdur in forum FormMail Subscription Support
    Replies: 6
    Last Post: 31-Jul-2004, 10:14 PM
  5. Form Attachments
    By Andy123 in forum FormMail Subscription Support
    Replies: 8
    Last Post: 09-Jul-2004, 08:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •