Results 1 to 8 of 8

Thread: PHP5 compatibility

  1. #1
    Join Date
    Oct 2007
    Posts
    1

    Default PHP5 compatibility

    Hi,

    I've got a short question. I have to upgrade to PHP5 and want to know if FormMail is compatible with PHP5? Is it possible that some errors can occur?

    I found no answer in forum or FAQs.

    Thank you very much!

  2. #2
    Join Date
    Aug 2007
    Posts
    78

    Default Re: PHP5 compatibility

    I have a site hosted on Hostgator.com that uses FormMail 8.03 and I was notified recently that Hostgator.com will be upgrading to PHP5.

    Is FormMail 8.03 compatible with PHP5?

    Thanks!

    Peace...

  3. #3
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: PHP5 compatibility

    Hi,

    Yes, FormMail works with PHP5.

    The only issues you're likely to come across are changes to the configuration of PHP that your hosting provider might perform.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  4. #4
    Join Date
    Aug 2007
    Posts
    78

    Default Re: PHP5 compatibility

    Great! Thanks!

    Peace...

  5. #5
    Join Date
    Jul 2008
    Posts
    13

    Default Re: PHP5 compatibility

    If your form is compatible with php5 then why do I get all these strict standard errors when clicking on the submit button with the fields missing or when the form is actually filled out?

    My form is here:
    http://www.designhosting.biz/quote.html

    I was told by one of the tectite techs that I needed to change the strict part of php5 but that didn't work. He also said the form was only compatible with php4 and not php5.

    Is there a way to fix the errors for php5?

  6. #6
    Join Date
    Aug 2007
    Posts
    78

    Default Re: PHP5 compatibility

    Quote Originally Posted by modom View Post
    If your form is compatible with php5 then why do I get all these strict standard errors when clicking on the submit button with the fields missing or when the form is actually filled out?

    My form is here:
    http://www.designhosting.biz/quote.html

    I was told by one of the tectite techs that I needed to change the strict part of php5 but that didn't work. He also said the form was only compatible with php4 and not php5.

    Is there a way to fix the errors for php5?
    I just submitted your form and didn't get any errors at all. I tried submitting an empty form and saw the page with the cop. Then, I filled it out with bogus info and it got submitted fine and I received the page, with the data I entered, and a print button.

    Is your problem resolved?

    Peace...

  7. #7
    Join Date
    Jul 2008
    Posts
    13

    Default Re: PHP5 compatibility

    I changed logging to a file and forms work now.

  8. #8
    Join Date
    Aug 2007
    Posts
    78

    Default Re: PHP5 compatibility

    Cool. How were you logging before?

    Peace...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Php5
    By 911bob in forum Community Support
    Replies: 10
    Last Post: 05-Feb-2009, 11:24 PM
  2. compatiblity with PHP5
    By jgold723 in forum Features Questions
    Replies: 6
    Last Post: 06-Nov-2008, 08:50 PM
  3. FormMail Windows IIS5.0, PHP5.2.6
    By SecureWIND in forum HOWTO Guides and Tips
    Replies: 2
    Last Post: 21-Oct-2008, 08:58 PM
  4. HTML compatibility?
    By ballen@morningstar in forum FormMail Subscription Support
    Replies: 5
    Last Post: 28-Feb-2005, 08:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •