Results 1 to 2 of 2

Thread: failed to open stream: no suitable wrapper could be found

  1. #1
    Join Date
    Oct 2007
    Posts
    1

    Default failed to open stream: no suitable wrapper could be found

    Hi Y'all,

    I started having this problem about a month ago. I setup PHP FormMail and got it to work without a hitch for about two months. Now, I'm getting this error:

    "The following error occurred in FormMail :
    Failed to open template "
    http://marltonag.org/magmail/plain.txt?USER_AGENT=Mozilla%2F4.0+%28compatible%3B+MSIE+7.0%3B+Windows+NT+5.1%3B+.NET+CLR+1.1.4322%3B+.NET+CLR+2.0.50727%3B+.NET+CLR+3.0.04506.30%3B+InfoPath.1%29&PHPSESSID=210b26bba9778e007f2b4bc99a86a7a7" : failed to open stream: no suitable wrapper could be found"

    The funny thing is that the email goes through just fine. So basically, I get a completed email and an error one to boot! It works, but I get an error generated too.

    Could this be a timing issue? I've checked the entire script and everything seems to be in order. I just get a false error!

    Any help would be apreciated. Thanks!

  2. #2
    Join Date
    Apr 2008
    Posts
    23

    Default Re: failed to open stream: no suitable wrapper could be found

    Here's a thread on the subject:

    http://www.tectite.com/vbforums/show...10659#poststop

    Basically, I think you need to set $TEMPLATEDIR instead of $TEMPLATEURL in the script.

    ginger
    So basically, I think it boils down to this: url_fopen() is disabled in your php.ini. Formmail uses that feature of php to open your template as a url.

    Documentation on php.net:

    http://us3.php.net/manual/en/filesys...llow-url-fopen

    And that is a setting that must be enabled in php.ini, can't be enabled at runtime.

    So if it's disabled, you won't be able to do server-side preprocessing in templates, as far as I know, unless your webhost can turn that on for you.

    TEMPLATEDIR should still work, since by that mechanism it's opening a local file, instead of a url.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failed to open CSV file
    By jibber in forum FormMail Subscription Support
    Replies: 6
    Last Post: 15-Sep-2005, 01:26 AM
  2. Upgrade failed
    By ptr in forum FormMail Subscription Support
    Replies: 1
    Last Post: 21-Jan-2005, 10:17 PM
  3. Can error page open in new window leaving original
    By Rezults in forum FormMail Subscription Support
    Replies: 3
    Last Post: 19-Nov-2004, 01:22 AM
  4. The requested URL was not found on this server.
    By aussieincanada in forum FormMail Subscription Support
    Replies: 1
    Last Post: 27-May-2004, 07:46 AM
  5. William,Failed to send email.
    By shama07 in forum FormMail Subscription Support
    Replies: 1
    Last Post: 31-Jan-2004, 03:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •