Results 1 to 3 of 3

Thread: Trouble loading fmcompute module

  1. #1
    Join Date
    Apr 2008
    Posts
    23

    Default Trouble loading fmcompute module

    So I set my

    Code:
    $MODULEDIR = "/home/mydomain.com/formproc/modules";
    and my

    Code:
    $FMCOMPUTE = "fmcompute.php";
    and the files are indeed in those directories, but I got:

    Error=Cannot load FMCompute module from file '/home/shanwhit/mydomain.com/formproc/modules/fmcompute.php': include_once() [<a href='function.include'>function.include</a>]: Failed opening '../tectite//home/shanwhit/mydomain.com/formproc/modules/fmcompute.php' for inclusion (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php')

    It appears that it's prepending "../tectite/" when trying to open it, so it looks like it will always fail unless I create a directory called "tectite" that's "../" to my tectite formmail.

    Looking in the source code, I found

    Code:
        if ($bAdvTemplates)
        {
            $FMCTEMPLATE_PROC = true;
            if (!include_once("../tectite/$MODULEDIR/$FMCOMPUTE"))
                Error("load_fmcompute",GetMessage(MSG_LOAD_FMCOMPUTE,
                                array("FILE"=>"$MODULEDIR/$FMCOMPUTE",
                                        "ERROR"=>$php_errormsg)),false,false);
        }
    and

    Code:
        if ($bAdvTemplates)
            $FMCTEMPLATE_PROC = true;
        if (!include_once("../tectite/$MODULEDIR/$FMCOMPUTE"))
            Error("load_fmcompute",GetMessage(MSG_LOAD_FMCOMPUTE,
                            array("FILE"=>"$MODULEDIR/$FMCOMPUTE",
                                    "ERROR"=>$php_errormsg)),false,false);
    Indeed, all the hooks are called in a similar way.

    So, I moved my modules directory to "../tectite/modules" and it started working fine.

    I'm not complaining, I just think it's a bit odd that you provide a way to configure MODULEDIR and HOOK_DIR, but then it's always assumed they are going to be under "../tectite/"



    So I thought I'd point that out.
    Last edited by aaron_w; 08-May-2008 at 11:06 PM.

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Trouble loading fmcompute module

    Hi,

    So, I moved my modules directory to "../tectite/modules" and it started working fine.

    I'm not complaining, I just think it's a bit odd that you provide a way to configure MODULEDIR and HOOK_DIR, but then it's always assumed they are going to be under "../tectite/"
    You're right it is odd.

    In fact it's so odd, I'm sure we didn't do it.

    Can you please check the version of FormMail you're using and let me know? Also, you can download a fresh copy and see if it has the same lines.

    I think you'll find it doesn't, and somehow you've inserted those "../tectite" strings yourself - maybe the edit you used repeated a command through the file?
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Apr 2008
    Posts
    23

    Default Re: Trouble loading fmcompute module

    Sure ...

    I'm using 8.05 ...

    Woah! You're right. I downloaded a fresh copy and the "../tectite" isn't in there at all. Well, shoot. Funny, I don't remember doing any "replace alls" when I was messing with the source code.

    Well, thanks for pointing that out and helping me notice that I must have inadvertently done something. I'm going to go back and start fresh.

    (embarrassed)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MAC OS X issue - anyone else having trouble?
    By Anasazi in forum FormMail Subscription Support
    Replies: 0
    Last Post: 27-Apr-2005, 07:54 PM
  2. Problem loading HTML Error Template
    By Webz in forum FormMail Subscription Support
    Replies: 3
    Last Post: 26-Feb-2005, 08:50 PM
  3. formmail trouble html or php file not sure
    By putertfix in forum FormMail Subscription Support
    Replies: 5
    Last Post: 25-Oct-2004, 08:11 AM
  4. Having trouble with the CC & BCC
    By madref in forum FormMail Subscription Support
    Replies: 5
    Last Post: 01-Oct-2004, 04:31 AM
  5. Mail Trouble
    By madref in forum FormMail Subscription Support
    Replies: 3
    Last Post: 30-Mar-2004, 10:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •