Results 1 to 1 of 1

Thread: Switched to a Windows server, now Form Mail is broken

  1. #1
    Join Date
    Jun 2008
    Location
    North Carolina
    Posts
    1

    Default Switched to a Windows server, now Form Mail is broken

    I've been using FormMail successfully for several months on my old web server (we'll call it OldServer). But, now that my hosting provider (a.k.a. my roommate) has built a new server (let's call it NewServer) and moved everything over to it, my FormMail stuff no longer works.

    When I try using the forms on NewServer, I get the "An error occurred while processing the form. Our staff have been alerted to the error." stuff. So, says I, why don't I start over, re-download a sample form from the site, and see if it works. Tried that and got the exact same error.

    So, I figured I would try the instructions in "Does your web server send mail?" Here's what I get:
    --With testmail.php, it tells me "Mail function FAILED"
    --With testmail2.php, it tells me "Mail function succeeded with -f parameter"

    So...following the instructions in that document, I changed the SENDMAIL_F_OPTION and SET_SENDER_FROM_EMAIL in my FormMail file from false to true. Reuploaded and tested it again, but I am still getting the same problem: "An error occurred while processing the form. Our staff have been alerted to the error."

    I should also note that, during all the times I tried these test messages, I did not once get any sort of confirmation or error message emailed to me. So I don't know if that means these things were supposed to email me at all, or if the mail just isn't getting sent. Even when I try the http://ussgalaxy.net/mail.php?testalert=1 URL with the sample form, it tells me a test message was sent and to check my mail, but I never get that test message.

    After that, I stumbled across "Does your server accept PHP?" I did as this page instructed and this is some of the info that it gives me on NewServer:
    --System: Windows NT 5.2 build 3790
    --Server API: Apache 2.0 Handler
    --Apache Version: Apache/2.2.8 (Win32) PHP/5.2.6

    (I didn't know if anything else on that phpinfo report is useful...)

    I knew that NewServer was running Windows, but that the web stuff is still running on Apache, because as my roommate puts it, "IIS is a steaming load of [expletive deleted]." OldServer was still using Apache, but was not running on Windows; I believe it was running Linux, but I'm not totally sure.

    I have a feeling that this is somehow related to a server misconfiguration of some sort, but I want to exhaust all options on my end before telling my roommate that he didn't do something right on his server. Plus, if I can get some theories and/or direction on what might be wrong with the server, that will hopefully make him more willing to fix whatever it is in a timely manner, rather than grumbling about it for months until he reluctantly gives in.

    My sample form and the test scripts are located here: http://ussgalaxy.net/testing/ if anyone wants to take a look at them to see if there is something I am missing. Any help you guys can give would be much appreciated.
    Last edited by sundancekat; 05-Jun-2008 at 06:41 PM. Reason: forgot a couple things the first time around

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Converting Underscores to Spaces from Form to E-mail
    By Kirk in forum FormMail Subscription Support
    Replies: 1
    Last Post: 01-Dec-2004, 06:20 AM
  2. Creating mail object using Mail::factory ("smtp", ....) and FormMail
    By stingray in forum FormMail Subscription Support
    Replies: 1
    Last Post: 13-Jul-2004, 09:27 PM
  3. Problem with new server sending mail
    By mstookey in forum FormMail Subscription Support
    Replies: 7
    Last Post: 25-Jun-2004, 01:27 AM
  4. Does your web server send mail?
    By russellr in forum FormMail Subscription Support
    Replies: 0
    Last Post: 10-Feb-2004, 08:19 AM
  5. Form Mail Questions
    By Ramius in forum FormMail Subscription Support
    Replies: 5
    Last Post: 12-Jan-2004, 03:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •