Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: I am having a cookie problem with my dynamic site.

  1. #11
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: I am having a cookie problem with my dynamic site.

    no probs....u might have sent it before - couldnt bother looking around

    ok, i logged in with IE7, ran the form a couple of times, and i'm still logged in

    i think this proves u have a local pc problem

    esp since u could even use IE

  2. #12
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    82

    Default Re: I am having a cookie problem with my dynamic site.

    Welcome aboard!

    If you click the link named "more" under our names. A popup will show you the ips! You will see five ip address! Two for me and two for you. There is one more ip address. That is my server and it should not work like this!
    Last edited by billy; 16-Dec-2008 at 11:54 PM.

  3. #13
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    82

    Default Re: I am having a cookie problem with my dynamic site.

    Quote Originally Posted by crabtree View Post
    no probs....u might have sent it before - couldnt bother looking around

    ok, i logged in with IE7, ran the form a couple of times, and i'm still logged in

    i think this proves u have a local pc problem

    esp since u couldn't even use IE

    Okay how would you relate that to the server then? Is the server not working correctly too?

    Plus I have other sites that dont behave this way at all. I just ran thru a few of them with no issues to report they work fine.
    Last edited by billy; 16-Dec-2008 at 11:55 PM.

  4. #14
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    82

    Default Re: I am having a cookie problem with my dynamic site.

    I am going to completely reboot this computer. I will dump all cache and cookies. I will be back in a few. I hope it is my computer. Seriously!

  5. #15
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: I am having a cookie problem with my dynamic site.

    Okay how would you relate that to the server then? Is the server not working correctly too?
    i dont know wot u mean.

    in what way is ur server not working? it seems fine to me

  6. #16
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    82

    Default Re: I am having a cookie problem with my dynamic site.

    Okay this is my very basic understanding of the issue.


    Cms session name = my_session

    formmail.php $SESSION_NAME = "my_session";

    My son added a little code to formmail in order to call the sessions with formmail and the cms the same session names.

    It didn't solve the whole problem it stills logs us out when on a page created thru formail. But when you go back around to the home page your automagically logged back in.

    So I will need to document this little issue further because it is a problem in my eyes. My son doesn't seem to think its that big of a deal.

  7. #17
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: I am having a cookie problem with my dynamic site.

    ok youve said that u r being logged out of ur cms when u use ur form

    i've tried it and it doesnt do that to me

    youve also said that u cannot even log into ur cms with IE

    i can

    doesnt that prove theres nothing wrong on the server and the problem is ur pc?

    confused

    My son added a little code to formmail in order to call the sessions with formmail and the cms the same session names.
    that sounds dnagerous.

    the SESSION_NAME config in formmail connects formmail to the same sesion. why do u want to add extra code that could be breaking things?

    it doesnt sound like ur approaching ur set of problems in a logical way - no offense intended

  8. #18
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    82

    Default Re: I am having a cookie problem with my dynamic site.

    Name for user cookies.
    This cookie contains only a user name and is saved in a user pc for a year (if the user wishes). If a user has this cookie, username will be automatically inserted in the login box.*

    Use custom session
    Select yes to customise session related values.* Yes No

    Session name
    The name of session (Valid only when 'use custom session' is enabled)*

    Session expiration
    Maximum duration of session idle time in minutes (Valid only when 'use custom session' is enabled. Works only when you are using PHP4.2.0 or later.)


    My son went thru and set all of this to be unique from formmail settings. That was a no go. So he went back thru and matched Session Name with the same in formmail.php

    Like I said It did solve half the problem. So I am kinda stuck atm and looking for another solution.

    I must say that we have slapped down most of the issues. This will also get solved as well. Its just a matter of time!
    Last edited by billy; 17-Dec-2008 at 01:04 AM.

  9. #19
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: I am having a cookie problem with my dynamic site.

    btw, i just went to ur cms again and im not still logged in

    so my guess is ur cms is writing a short-term cookie....

    i just tried to check but it doesnt allow me to log in

    so, i guess thats why im not still logged in

    really sounds like ur getting into a frazzled mess...

    i think u should slow down and fix one problem at a time

    changing things randomly just gets u no where and wastes heaps of time

  10. #20
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: I am having a cookie problem with my dynamic site.

    My son went thru and set all of this to be unique from formmail settings. That was a no go. So he went back thru and matched Session Name with the same in formmail.php
    if it was me, i'd want to understand why

    u only need a different session name

    if the session names are different, then they wont interfere (make sure u have version 8.11 of Formmail and u set DESTROY_SESSION to false)

    if they do interfere then u need to understand why before chaning anything

    u need to understand, not guess

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Site needs some organization
    By Godan in forum HOWTO Guides and Tips
    Replies: 3
    Last Post: 26-Nov-2006, 03:21 AM
  2. FormMail works on localhost but not users live site
    By WyleySam in forum Community Support
    Replies: 1
    Last Post: 26-Jul-2006, 11:31 PM
  3. A return Web Site in all success replys
    By sbboyd in forum Features Questions
    Replies: 3
    Last Post: 26-Jul-2006, 11:29 PM
  4. Formmail problems in a site with frames
    By PieterToo in forum Community Support
    Replies: 0
    Last Post: 01-Jun-2006, 08:10 PM
  5. dynamic php generated html email not working
    By scrypton in forum FormMail Subscription Support
    Replies: 6
    Last Post: 03-Dec-2005, 11:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •