Results 1 to 4 of 4

Thread: 8.11: Broken header with combination of email and replyto (Reply-To)

  1. #1
    Join Date
    Jan 2009
    Posts
    24

    Exclamation 8.11: Broken header with combination of email and replyto (Reply-To)

    Same form with a reply to field, with and without email field set. With email set [1] Reply-To function is not working [2] Reply-To, Message-Id and Date are added to the top of the body of the email message.

    ---
    Return-Path: <_www@host.net>
    Received: from host.net ([unix socket])
    by host.net (Cyrus v2.3.8-OS X Server 10.5: 9C31) with LMTPA;
    Thu, 01 Jan 2009 21:41:30 +0100
    X-Sieve: CMU Sieve 2.3
    Received: by host.net (Postfix, from userid 70)
    id 11416D333D7; Thu, 1 Jan 2009 21:41:30 +0100 (CET)
    To: info@recipient.net
    Subject: 10
    From: _www@host.net (user 10)
    Message-ID: <cmu-lmtpd-11367-1230842490-0@host.net>
    Date: Thu, 01 Jan 2009 21:41:30 +0100

    Reply-To: user@otherhost.net
    Message-Id: <20090101204130.11416D333D7@host.net>
    Date: Thu, 1 Jan 2009 21:41:30 +0100 (CET)

    email: _www@host.net
    realname: user 10
    message: 10
    Submit: Versturen

    ==================================

    REMOTE_HOST=
    REMOTE_ADDR=1.2.3.4
    HTTP_USER_AGENT=Mozilla/5.0 (Macintosh; U; Intel Mac OS X; nl; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 FireShot/0.32
    REMOTE_USER=

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: 8.11: Broken header with combination of email and replyto (Reply-To)

    Hi,

    I think this is a bug on your server.

    The Reply-To and Message-ID header lines have been preceded by a blank line and that's why they've appeared in the body.

    Why is your server adding this blank line?

    FormMail cannot set the the header lines directly - it provides the header values and your email server formats them.

    I recommend you direct your investigation to your server 's email software.

    For example, why are there two Date: headers?

    Perhaps the first Date: header has an extra new-line at the end.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Jan 2009
    Posts
    24

    Question Re: 8.11: Broken header with combination of email and replyto (Reply-To)

    Could you please give me a hint on how to investigate this matter?
    The server is a stock Apple Xserve, with Mac OS X server 10.5.6 installed.

  4. #4
    Join Date
    Jan 2009
    Posts
    24

    Default Re: 8.11: Broken header with combination of email and replyto (Reply-To)

    Thanks for the reply on http://www.tectite.com/vbforums/showthread.php?t=3484
    after just not specifying replyto and use email as from address, the Return-Path: <_www@host.net> is still set to something different as the user entered from address, which solves the blank line in the headers problem.

    This all is caused by my misinterpretation betweeen Return-Path and From header.

    Thanks for your really quick replies. I do hope you find time to work on your ToDo list, besides giving this excellent support.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Forcing charset in e-mail header
    By Wojtek in forum FormMail Subscription Support
    Replies: 14
    Last Post: 22-Feb-2005, 08:28 AM
  2. Session and Header errors
    By orange in forum FormMail Subscription Support
    Replies: 2
    Last Post: 09-Dec-2004, 01:16 AM
  3. Removing empty variables from eMail reply
    By Prospero in forum FormMail Subscription Support
    Replies: 4
    Last Post: 25-Jul-2004, 07:22 AM
  4. HTML email reply
    By aussieincanada in forum FormMail Subscription Support
    Replies: 5
    Last Post: 04-Jun-2004, 06:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •