Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: Email error message - "no_valid_recipients"

  1. #11
    Join Date
    Sep 2009
    Posts
    48

    Default Re: Email error message - "no_valid_recipients"

    The webpage of the form is www.emstravel.co.uk/contact_form.htm

    The confirmation page is www.emstravel.co.uk/contact_thankyou.htm

    The automatic emails are www.emstravel.co.uk/autoresponse_email.htm
    and www.emstravel.co.uk/_private/autoresponse_email.txt

    When the form is submitted I get the form info now, but the form user is taken to a page that cannot be displayed and the automatic emails don't get sent.

    can any one help?

  2. #12
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    378

    Post Re: Email error message - "no_valid_recipients"

    Your confirmation page is not correct. If I click on your link above I get the 404 page.

    Make sure you have the address correct.

  3. #13
    Join Date
    Sep 2009
    Posts
    48

    Default Re: Email error message - "no_valid_recipients"

    Fixed the code you gave me. Thanks

    I now get these error messages

    To: mick.bullous@inbox.com
    From: FormMail@www.emstravel.co.uk

    The following error occurred in FormMail :
    Failed to open template "
    http://www.emstravel.co.uk/autoresponse_email.htm,http://emstravel.co.uk/_private/autoresponse.txt/autoresponse_email.txt?USER_AGENT=Mozilla%2F4.0+%28compatible%3B+MSIE+8.0%3B+Windows+NT+6.0%3B+Trident%2F4.0%3B+SU+3.23%3B+SLCC1%3B+.NET+CLR+2.0.50727%3B+.NET+CLR+3.5.30729%3B+.NET+CLR+3.0.30618%29&PHPSESSID=63ee85810c221270145003e9a76c4957" : failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found

    and

    To: mick.bullous@inbox.com
    From: FormMail@www.emstravel.co.uk

    The following error occurred in FormMail :
    Autoresponder failed

    email:
    mick.bullous@inbox.com
    realname: Fred Bloggs

    company: 'Bloggs and Co'
    tel: '07784841366'
    comments: 'Test this form'
    Referring page was
    http://www.emstravel.co.uk/contact_form.htm
    SERVER_NAME was www.emstravel.co.uk
    REQUEST_URI was /formmail.php

    User IP address was 94.2.64.230
    User agent was Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SU 3.23; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30618)

  4. #14
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    378

    Post Re: Email error message - "no_valid_recipients"

    Your confirmation page is
    Code:
    http://www.emstravel.co.uk/_private/contact_thankyou.htm
    You have www.esm... on your form. Just a typo.

  5. #15
    Join Date
    Sep 2009
    Posts
    48

    Default Re: Email error message - "no_valid_recipients"

    I now get this error message. I don't think the confirmation page will appear until all errors are resolved. Is this the case and do you know where i have gone wrong with the auto response?

    To: mick.bullous@inbox.com
    From: FormMail@www.emstravel.co.uk

    The following error occurred in FormMail :
    Some autorespond settings are undefined :
    http://www.emstravel.co.uk/_private/autoresponse_email.txt

    email:
    realname:


    Referring page was
    http://www.emstravel.co.uk/contact_form.htm
    SERVER_NAME was www.emstravel.co.uk
    REQUEST_URI was /formmail.php

    User IP address was 94.2.64.230
    User agent was Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SU 3.23; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30618)

  6. #16
    Join Date
    Sep 2009
    Posts
    48

    Default Re: Email error message - "no_valid_recipients"

    I can see that you are using the form but I get this error message as well as the form info

    To: mick.bullous@inbox.com
    From: FormMail@www.emstravel.co.uk

    The following error occurred in FormMail :
    Some autorespond settings are undefined :
    http://www.emstravel.co.uk/_private/autoresponse_email.txt

    email:
    realname:


    Referring page was
    http://www.emstravel.co.uk/contact_form.htm
    SERVER_NAME was www.emstravel.co.uk
    REQUEST_URI was /formmail.php

    User IP address was 98.199.79.173
    User agent was Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; MS-RTC LM 8; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; InfoPath.2)

  7. #17
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    378

    Post Re: Email error message - "no_valid_recipients"

    Change your hidden field to:
    Code:
    <input type="hidden" name="autorespond" value="http://www.emstravel.co.uk/_private/...onse_email.txt Subject=Thanks for submitting your enquiry!,TemplateMissing=" /><div align="center">
    You have a couple of extra quotes in there.

  8. #18
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    378

    Post Re: Email error message - "no_valid_recipients"

    Sorry, you also need a comma after the address and before the Subject.

  9. #19
    Join Date
    Sep 2009
    Posts
    48

    Default Re: Email error message - "no_valid_recipients"

    Ok Thanks for your help.

    Here's where we are at with this...
    1. The form sends the users info to me ok
    2. The confirmation page opens on form submitting.
    Here's what I can't get to work!!!
    1. The form information does not go into the fields on the confirmation page
    2. The autoresponse.txt email doesn't get sent
    This is doing my head in now.

    My settings are below:

    <form method="post" action=http://www.emstravel.co.uk/formmail.php>
    <input type="hidden" name="env_report" value="REMOTE_HOST,REMOTE_ADDR,HTTP_USER_AGENT,AUTH_TYPE,REMOTE_USER" />

    <input type="hidden" name="recipients" value="mick.bullous@inbox.com" />

    <input type="hidden" name="required" value="realname:,email:,tel:,enquiry_about:,comments:,arverify," />

    <input type="hidden" name="subject" value="Contact Form Web Enquiry" />

    <input type="hidden" name="good_url" value="http://www.emstravel.co.uk/_private/contact_thankyou.htm" />

    <input type="hidden" name="good_template" value="path/to/http://www.emstravel.co.uk/_private/contact_thankyou.htm" />

    <input type="hidden" name="autorespond" value="http://www.emstravel.co.uk/_private/autoresponse_email.txt,Subject=Thank You for submitting your enquiry!,TemplateMissing=" />

    This is the email Error message I now get

    To: mick.bullous@inbox.com
    From: FormMail@www.emstravel.co.uk

    The following error occurred in FormMail :
    Some autorespond settings are undefined :
    http://www.emstravel.co.uk/_private/autoresponse_email.txt

    email:
    realname:


    Referring page was http://www.emstravel.co.uk/contact_form.htm
    SERVER_NAME was www.emstravel.co.uk
    REQUEST_URI was /formmail.php

    User IP address was 94.2.64.230
    User agent was Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SU 3.23; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30618)
    Last edited by Mickyboy; 05-Sep-2009 at 12:56 AM. Reason: missing info

  10. #20
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    378

    Post Re: Email error message - "no_valid_recipients"

    [quote=Mickyboy;16177]

    Here's what I can't get to work!!!
    1. The form information does not go into the fields on the confirmation page
    2. The autoresponse.txt email doesn't get sent
    quote]

    1. You are using a good_url rather than a good_template. good_url is static. You have to use good_template to get the values on the confirmation page. Let's fix that later.

    2. Did you setup TEMPLATEDIR or TEMPLATEURL in your formmail.php file?
    Last edited by jzieba; 05-Sep-2009 at 01:08 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no_valid_recipients error message
    By edenexcursions in forum FormMail Subscription Support
    Replies: 17
    Last Post: 06-Aug-2004, 12:39 AM
  2. Spiders and "The form has an internal error"
    By russellr in forum FormMail Subscription Support
    Replies: 0
    Last Post: 13-May-2004, 09:11 PM
  3. Email contains no "mesg"
    By xuric in forum FormMail Subscription Support
    Replies: 1
    Last Post: 19-Apr-2004, 08:17 PM
  4. Error Message on Optus
    By paf in forum FormMail Subscription Support
    Replies: 6
    Last Post: 12-Jan-2004, 11:43 AM
  5. Error Message
    By cuffs in forum FormMail Subscription Support
    Replies: 4
    Last Post: 11-Jan-2004, 04:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •