Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Tests Fine but no form emails

  1. #21
    Join Date
    Sep 2009
    Posts
    14

    Default Re: Tests Fine but no form emails

    i get alerts when I do the test and when there was an error. I have never gotten an actual form submission. Heck if I got an alert for each form submission just telling me that it was submitted I could use the data in it. So I am not sure. But the Emails for the alerts and for my form submissions is the same. let me copy what I have in there.


    So should I change the fixed sender to "chris@emedic1973.com"?

    $TARGET_EMAIL = array("^chris@emedic1973\.com$",
    "^lisa@emedic1973\.com$", "^christopher\.rhea\@gmail\.com$");

    /* Help: http://www.tectite.com/fmdoc/def_alert.php */
    define("DEF_ALERT","chris@emedic1973.com");

    $FIXED_SENDER = "webmaster@emedic1973.com";

  2. #22
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Tests Fine but no form emails

    So should I change the fixed sender to "chris@emedic1973.com"?
    no.

    when u get an alert, it has From address.

    is it "webmaster@emedic1973.com"?

    if so, then wot u have is right. if not, change FIXED_SENDER to that address

    do u or ur ISP have a spam filter on chris@emedic1973.com?

  3. #23
    Join Date
    Sep 2009
    Posts
    14

    Default Re: Tests Fine but no form emails

    i dont believe I have any filter on my other email account. the chris@emedic1973.com one. I never set anything up except the name.

  4. #24
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Tests Fine but no form emails

    ok, pls answer my other question:

    is the From address in alerts the same as ur FIXED_SENDER value?

    if so, now add this to ur HTML form:
    HTML Code:
    <input type="hidden" name="mail_options" value="FromAddr=webmaster@emedic1973.com" />
    and test again

  5. #25
    Join Date
    Sep 2009
    Posts
    14

    Default Re: Tests Fine but no form emails

    yes it was. I am putting the HTML code in now and retrying.

  6. #26
    Join Date
    Sep 2009
    Posts
    14

    Default Re: Tests Fine but no form emails

    it just sent the FORM data. AWESOME thanks

  7. #27
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Tests Fine but no form emails

    good

    u probly don't need FIXED_SENDER. u can leave it or remove its value:
    HTML Code:
    $FIXED_SENDER = "";
    and test again.

    btw, here's what the emailproblems document says:
    The next step is to try the FromAddr feature of mail_options. This involves selecting a valid email address in your domain (website) that is, preferably, different to the email address that receives your form results.
    i thought u said u followed all the steps.

  8. #28
    Join Date
    Feb 2009
    Posts
    12

    Default Re: Tests Fine but no form emails

    The following error occurred in FormMail :
    no_valid_recipients
    **********
    Error=The form has an internal error - no valid recipients were specified.
    The reason i think you are getting the error and not getting emails is that the email address you specified in your form's recipients is different from the one you specified in your formmail.php target email.

    Example: In your form you have this
    <input type="hidden" name="recipients" value=you@yourdomain.com />
    but in the formmail target email you have this
    $TARGET_EMAIL = array("^me@yourdomain\.com$")
    Check it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sending me two emails
    By srolls in forum FormMail Subscription Support
    Replies: 2
    Last Post: 20-Sep-2004, 11:15 PM
  2. no emails being sent
    By dunn123 in forum FormMail Subscription Support
    Replies: 1
    Last Post: 13-Sep-2004, 12:19 PM
  3. only two emails every ten minutes?
    By vynsane in forum FormMail Subscription Support
    Replies: 4
    Last Post: 26-May-2004, 09:00 PM
  4. not receiving emails
    By ctpiper in forum FormMail Subscription Support
    Replies: 1
    Last Post: 22-Apr-2004, 09:29 PM
  5. Formmail works fine, but no e-mail
    By Wiggy in forum FormMail Subscription Support
    Replies: 1
    Last Post: 08-Jan-2004, 04:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •