Results 1 to 2 of 2

Thread: Return Link and Multi form Back buttons not working

  1. #1
    Join Date
    Feb 2010
    Posts
    3

    Default Return Link and Multi form Back buttons not working

    Hi Russell,

    I've set up a multipage form which works fine going forward, but if you need to go back using either the return_link or the multi-form back button I get an error.

    The link to the first page of the form is:

    http://www.schoolsoutclub.com/forms/registration1.php

    The last page is: http://www.schoolsoutclub.com/forms/...rationEnd.html

    The quickest way to test it is just to scroll down to the next button and then click the 'return to form' link at the bottom of the page. The 'go back' link is just a javascript link I've been using whilst testing.

    The error I'm getting using the return link is:

    Cannot open form URL: http://www.schoolsoutclub.com/forms/registration1.php?


    The error when using the 'multi_go_back' link is shown by fmbadhandler and is 'Your form submission has failed due to an error on our server'. This back link was working before I started using fmbadhandler

    Here are my main settings:

    Fmbadhandler and Formmail:

    $TARGET_URLS = array("http://www.schoolsoutclub.com","http://schoolsoutclub.com");

    $TEMPLATEDIR = "/home/sites/schoolsoutclub.com/public_html/forms";

    $TEMPLATEURL = "http://www.schoolsoutclub.com/forms";


    Formmail:

    $MULTIFORMDIR = "/home/sites/schoolsoutclub.com/public_html/forms";
    $MULTIFORMURL = "http://www.schoolsoutclub.com/forms";

    define("PUT_DATA_IN_URL",false);

    Any help would be really appreciated,

    All the best,

    Andy

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Return Link and Multi form Back buttons not working

    Hi,

    I note that going back from page 3 to page 2 is OK.

    But, it's just getting back to page 1 that's the problem. Correct?

    I can't see anything obvious.

    But, please remove the setting for $MULTIFORMDIR. Since this is set, the $MULTIFORMURL setting is ignored.

    I'm interested to know whether going forward works if you just have $MULTIFORMURL set.

    Also, can you please email me your FormMail and FMBadHandler scripts, so I can check out all the settings?

    Please email to supportstaff AT tectite DOT com.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fmbadhandler link back problem
    By frankherzog in forum FormMail Subscription Support
    Replies: 6
    Last Post: 25-Nov-2004, 10:58 AM
  2. Return All Variables To Form Page On Error
    By cornernote in forum FormMail Subscription Support
    Replies: 12
    Last Post: 31-Oct-2004, 09:20 PM
  3. Link to your own REDIRECT page?
    By cottonslurpy in forum FormMail Subscription Support
    Replies: 2
    Last Post: 17-Jun-2004, 08:36 PM
  4. Return All Variables To Bad_Form Page On Error
    By vladimir in forum FormMail Subscription Support
    Replies: 2
    Last Post: 07-Jun-2004, 05:13 PM
  5. No return link for badhandler
    By ptr in forum FormMail Subscription Support
    Replies: 3
    Last Post: 26-May-2004, 11:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •