Results 1 to 4 of 4

Thread: Payment Form Doesn't Work in Chrome

  1. #1
    Join Date
    Sep 2010
    Posts
    2

    Default Payment Form Doesn't Work in Chrome

    Hello,

    I did a quick search on the forums for known Chrome issues and only found one thread similar to the issue I'm experiencing: http://www.tectite.com/vbforums/show...ghlight=chrome Unfortunately, there didn't seem to be a resolution posted for the issue.

    My problem is with a payment form not submitting correctly in Chrome, but working fine in IE and FireFox. The form in question is: https://www.bluechannel.com/pay-invoice.htm

    The recipients field has an AT_MANGLE setup on it, which is defined in my formmail.php file. The TARGET_EMAIL array is setup as: array(EMAIL_NAME."@bluechannel\.com$");

    Submitting the form on Chrome gives me this error:
    An error occurred while processing the form .

    The staff at www.bluechannel.com have been alerted to the error .
    www.bluechannel.com apologizes for any inconvenience this error may have caused.

    The email alert I receive is:
    The following error occurred in FormMail :
    no_recipients
    **********
    Error=The form has an internal error - no actions or recipients were specified.

    email:
    realname:

    Referring page was https://www.bluechannel.com/pay-invoice.htm

    I've tried removing the AT_MANGLE requirement from both formmail.php and the hidden recipients field and have the same error. I also tried using "^info@bluechannel\.com$" for the TARGET_EMAIL variable instead of the EMAIL_NAME constant, but that didn't work either.

    Any insight is greatly appreciated.

  2. #2
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Payment Form Doesn't Work in Chrome

    Hi,

    Remove "enctype=text" from your form which will then force the default enctype to be used.

    I think that will solve your problem.

    ginger

  3. #3
    Join Date
    Sep 2010
    Posts
    2

    Default Re: Payment Form Doesn't Work in Chrome

    Great catch. This fixed the issue!

    Thanks so much.

  4. #4
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Payment Form Doesn't Work in Chrome

    Glad it helped.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sample form works but I can't make the form in my HTML work
    By hnaegele in forum FormMail Subscription Support
    Replies: 7
    Last Post: 07-Sep-2007, 01:04 AM
  2. Cant get good url to work (after 6h work)
    By BadDevil in forum Community Support
    Replies: 8
    Last Post: 29-Jan-2007, 12:15 AM
  3. your form simply does not work!
    By artmaker in forum Community Support
    Replies: 5
    Last Post: 26-Aug-2006, 11:04 AM
  4. your form simply does not work!
    By artmaker in forum Bug Reports
    Replies: 0
    Last Post: 22-Aug-2006, 12:20 AM
  5. Cannot get form to work
    By comptroub in forum FormMail Subscription Support
    Replies: 12
    Last Post: 13-Nov-2005, 03:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •