Results 1 to 3 of 3

Thread: Problems with fmbadhandler in Firefox and Safari?

  1. #1
    Join Date
    May 2008
    Posts
    1,291

    Default Problems with fmbadhandler in Firefox and Safari?

    Hi,

    I'm having a problem when trying to return to the form when I'm using Firefox or Safari. What happens is when I try to return to the form I get the error:

    "Cannot open form URL: http://www.domain.com/contact.php?US...hj35g55ltode33&: Failed: 404 Not Found"

    If I copy and paste that url (without the querystring) I get the contact page just fine.

    The versions I'm working with are:

    Firefox 3.6.12 on Windows XP
    Safari 3.1.2 on Windows XP
    fmbadhandler.php - v1.21
    formmail.php - v8.24

    IE (v8.0) seems to be OK. It returns to the form with entered data intact.

    I have:
    Code:
    define("PUT_DATA_IN_URL", false);
    I've defined $TARGET_URLS as:
    Code:
    $TARGET_URLS = array("http://www.domain.com");
    There's a redirect to the www version in the .htaccess file, so I don't have the non-www url in there, but I've tested it both ways just in case.

    Any ideas?

    Thanks!

    ginger

  2. #2
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Problems with fmbadhandler in Firefox and Safari?

    it sounds strange that its browser-specific

    since the user agent is included in the url, i wonder if the server doesnt like something in the user agent string for some browsers?

    bottom line: i dunno

    i think this is a job for russ

  3. #3
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Problems with fmbadhandler in Firefox and Safari?

    Hi,

    I agree with crabtree...it sounds like the server is rejecting the query string.

    You said copy-and-paste to the browser works without the query string, does it work with it?

    But, the fact that it works with a particular browser suggests that it's not the query string per se, but something within the query string.

    Thanks for all your support of other users on the forums.

    I'm happy to look into this for you in detail. Just contact me by email or PM and we'll discuss it further there.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. problems to display template.
    By minorarias in forum FormMail Subscription Support
    Replies: 3
    Last Post: 31-Jan-2005, 09:23 PM
  2. mail_options and template problems
    By middric in forum FormMail Subscription Support
    Replies: 1
    Last Post: 09-Jan-2005, 08:29 PM
  3. Template problems
    By msoucy in forum FormMail Subscription Support
    Replies: 8
    Last Post: 03-Dec-2004, 04:31 AM
  4. csv file problems
    By Badnet in forum FormMail Subscription Support
    Replies: 2
    Last Post: 12-Nov-2004, 02:06 AM
  5. Badhandler Problems
    By Jacob in forum FormMail Subscription Support
    Replies: 3
    Last Post: 17-Aug-2004, 08:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •