Results 1 to 3 of 3

Thread: Another Invalid Email Recipients Thread

  1. #1
    Join Date
    Oct 2011
    Posts
    2

    Default Another Invalid Email Recipients Thread

    Hey guys,

    I'm in desperate need of help... I keep getting the invalid recipients error and I can't for the life of me work out what I'm doing wrong... I have the PHP code as follows:

    $TARGET_EMAIL = array(EMAIL_NAME."@insurance-made-easy\.com\.au$");

    I've tried changing this to a specific email address like so:

    $TARGET_EMAIL = array("^insurance@insurance-made-easy\.com\.au$");

    but still no luck.

    Within my html code I specified the recipients as follows:

    <form method="post" action="http://insurance-made-easy.com.au/home/formmail.php" name="InfoForm">
    <input type="hidden" name="env_report" value="REMOTE_HOST,REMOTE_ADDR,HTTP_USER_AGENT,AUTH_TYPE,REMOTE_USER" />
    <input type="hidden" name="recipients" value="insurance@insurance-made-easy.com.au" />

    I've tried changing the action to "formmail.php", I've tried using things like ATT instead of the @ symbol, I found a thread (http://www.tectite.com/vbforums/show...d-quot-notices) which seemed to say I should use a comma instead of a full stop after the EMAIL_NAME and that seemed to work except the email didn't send and I just got the same alert he was getting as follows:


    The following potential problems were found in your configuration:Warning: Your TARGET_EMAIL pattern "^[-a-z0-9.]+" is missing a $ at the end. Warning: Your TARGET_EMAIL pattern "@insurance-made-easy\.com\.au$" is missing a ^ at the beginning.Can someone please please please tell me what I'm doing wrong... as far as I can see I've got the TARGET_EMAIL value right... maybe it has something to do with the "-" in the domain name? Please help me!

  2. #2
    Join Date
    Oct 2011
    Posts
    2

    Default Re: Another Invalid Email Recipients Thread

    Further to this, I just tried out the test email with the following results:


    To: insurance@insurance-made-easy.com.auFrom: FormMail@www.insurance-made-easy.com.auThis is a test alert message Loaded language is English (builtin)PHP version is 5.2.8FormMail version is 8.29Server type: non-WindowsDOCUMENT_ROOT: /home/insuranc/public_htmlSCRIPT_FILENAME: /home/insuranc/public_html/home/formmail.phpPATH_TRANSLATED: -not set-REAL_DOCUMENT_ROOT: /home/insuranc/public_htmlSERVER_NAME was www.insurance-made-easy.com.auREQUEST_URI was /home/formmail.php?testalert=1User IP address was 175.33.233.171User agent was Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)Does that help?

  3. #3
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Another Invalid Email Recipients Thread

    $TARGET_EMAIL = array(EMAIL_NAME."@insurance-made-easy\.com\.au$");

    $TARGET_EMAIL = array("^insurance@insurance-made-easy\.com\.au$");
    either of these s correct and will not cause the error ur seeing.

    therefore....ur form is not submitting to the copy of Formmail u think u have.

    perhaps u forgot to upload after changing, or uploaded to the wrong place.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Invalid Email Address
    By mkrmarks in forum Community Support
    Replies: 2
    Last Post: 15-Oct-2010, 03:34 PM
  2. Invalid Email
    By pj100uk in forum Community Support
    Replies: 1
    Last Post: 11-Jun-2010, 08:25 PM
  3. delete thread
    By RobMan in forum Community Support
    Replies: 3
    Last Post: 29-May-2008, 11:02 PM
  4. invalid recipients????
    By digitalrain in forum FormMail Subscription Support
    Replies: 4
    Last Post: 16-Dec-2005, 11:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •