Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Autoresponder Problems

  1. #1
    Join Date
    Aug 2009
    Posts
    21

    Default Autoresponder Problems

    Hello everyone,

    First off I want to say how much I love this site and its forms. I have been using it for years with absolutely no problems. So... I want to use the autorespond feature but for some reason cannot get it to work. I have read the FAQs and how to guide and it still craps out.

    I currently have a form using Captcha and everything works fantastic with no errors. All I want to do is send a simple confirmation email that lists what was put in the form.

    Can someone please give me simple steps on how to do this? I follow the guide but it still doesnt work.

    Please if anyone can help it would be much appreciated.

    Thanks.
    Dan

  2. #2
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Autoresponder Problems

    if u already have captcha working, then u simply need to derive a field called "arverify" from the current captcha field "imgverify".

    HTML Code:
    <input type="hidden" name="derive_fields" value="arverify=imgverify" />
    then add in ur autorespond hidden field to specify wot u want it to do.

  3. #3
    Join Date
    Aug 2009
    Posts
    21

    Default Re: Autoresponder Problems

    Thanks for rsponding. This is what I have in my form:

    <input type="hidden" name="derive_fields" value="imgverify=Turing" />

    then I added this for autorespond
    <input type="hidden" name="derive_fields" value="arverify=imgverify" />
    <input type="hidden" name="autorespond" value="PlainTemplate=email.txt,Subject=Stuff,FromAddr=email@es.ca,TemplateMissing=" />

    Again, the form works fine without the autorespond, I am using the Captchacreator verification - not the google.

    Please help. I feel that i must be missing something small.

    When i try the form I get the following:

    "An error occurred while processing the form .

    The form required some values that you did not seem to provide.
    Please enter the correct image characters - press your back button and try again"

    I need help
    Dan

  4. #4
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: Autoresponder Problems

    u can't add a second derive_fields field - HTML doesn't let u

    instead:
    HTML Code:
    <input type="hidden" name="derive_fields" value="imgverify=Turing,arverify=Turing" />

  5. #5
    Join Date
    Aug 2009
    Posts
    21

    Default Re: Autoresponder Problems

    Thank you for that part. It is now letting me submit the form with captcha. BUT i now get the following errors:

    1 email says:
    The following error occurred in FormMail :
    Autoresponder failed

    2nd email says:
    The following error occurred in FormMail :
    Failed to open template "www.xxxxx.ca/receipt/templates/email.txt" : fopen(www.xxxxx.ca/receipt/templates/email.txt) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory

    The directory is there. And the email.txt file is there?

    I am so close

    Dan

  6. #6
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Autoresponder Problems

    Hi,

    Not sure if the first message is related to the second, but the second error message indicates a path problem. Are you using $TEMPLATEDIR or $TEMPLATEURL (you shouldn't be using both). If you're using $TEMPLATEDIR you need to get the "server path" to your template directory. You can get this from your host, or you can run testalert (http://yourdomain.com/path-to-formmail.php?testalert=1) . You should then receive an email with the server path to your document root, which should be enough for you to tell the path to the template directory.

    ginger

  7. #7
    Join Date
    Aug 2009
    Posts
    21

    Default Re: Autoresponder Problems

    I am using the $TemplateURL and the path is correct. The folder has the txt file. Everything seems right, but for some reason everytime I use the form I get a good email send using the captcha, but my autorespond address gets 2 emails.

    1. The following error occurred in FormMail :
    Autoresponder failed

    2. The following error occurred in FormMail :
    Failed to open template "www.xxx/receipt/templates/receiptEmailTemplate.txt" : fopen(www.xxx/receipt/templates/receiptEmailTemplate.txt) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory

    The file is there and so is the directory. When I copy and past the link to the text file in the browser it comes up so i know the path is correct.

    I dont know what else to do. Is there something else I can post that can identify my problem?

    Dan

  8. #8
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Autoresponder Problems

    Looks like you're missing the "http://" portion of the url. See if that solves the problem.

    ginger

  9. #9
    Join Date
    Aug 2009
    Posts
    21

    Default Re: Autoresponder Problems

    I am so sorry to be a bother. I have added the http, but it is still doing the same thing. Here is all my info. Hopefully its something small, but I just cant see it.

    <input type="hidden" name="derive_fields" value="imgverify=Turing,arverify=Turing" />
    <input type="hidden" name="autorespond" value="PlainTemplate=email.txt,Subject=Your Program Receipt,FromAddr=webmaster@xxxxx.ca,TemplateMissing=" />

    $TEMPLATEURL = "http://www.xxxxx.ca/receipt/templates";
    $TEMPLATEDIR = "";

    Their is a txt file in the template folder (email.txt). The form and handler is in the receipt folder.

    I am getting the following errors:

    email 1:
    The following error occurred in FormMail : Autoresponder failed

    email 2:
    The following error occurred in FormMail :
    Failed to open template "www.es-hockey.ca/receipt/templates/receiptEmailTemplate.txt" : fopen(http://www.es-hockey.ca/receipt/temp...ilTemplate.txt) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory

    email 3:
    successful submission of form.

    I did have this working properly last year but with the older version of formmail.

    Help! Thanks for checking this out. I appreciate it.
    Dan

  10. #10
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Autoresponder Problems

    What is the name of your autorespond template: email.txt or receiptEmailTemplate.txt?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AutoResponder From
    By Wade in forum Features Questions
    Replies: 21
    Last Post: 03-Sep-2010, 12:51 AM
  2. Autoresponder Problems
    By jackibar in forum Community Support
    Replies: 0
    Last Post: 12-Mar-2008, 04:23 AM
  3. help with autoresponder
    By ambmom in forum FormMail Subscription Support
    Replies: 4
    Last Post: 01-Sep-2006, 01:58 AM
  4. AutoResponder Help
    By Chek in forum FormMail Subscription Support
    Replies: 2
    Last Post: 29-Apr-2005, 01:48 PM
  5. autoresponder
    By chadt in forum FormMail Subscription Support
    Replies: 1
    Last Post: 31-Mar-2005, 11:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •