Results 1 to 10 of 10

Thread: Error=Filter "encode" failed (status 126)

  1. #1
    Join Date
    Nov 2011
    Posts
    4

    Default Error=Filter "encode" failed (status 126)

    I've set up formmail.php to work so that it is able to send unencrypted emails and it works fine. When I setup my forms to "encode" I get the error message that it failed as stated in the subject above (status 126).

    I've searched your forum and found someone who had the same issue. That person was told that if fmencoder is set up with the correct file permissions that the problem must lie in the subdirectories leading up to it. Therefore, I contacted my hosting company (ipage) and they told me that it was a scripting error. They tested another php file in my cgi-bin and it worked fine.

    So, I've played around with the script again with no luck. The latest thing I've tried was setting $SOCKET_FILTERS. I changed my form to <input type="hidden" name="filter" value="httpencode" />
    The result was Error=Could not connect to site www.blahblah.com for filter "httpencode" (110): Connection timed out (fosckopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to www.blahblah.com:80 (Connection timed out))

    Your help would be appreciated.

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Error=Filter "encode" failed (status 126)

    Hi,

    It could be that the file has been corrupted on upload - make sure you upload it as binary.

    Also, is it the right binary for your server operating system?

    It could also be that your server refuses to execute the binary.

    Your hosting provider *should* be able to tell you what's wrong - executing a program or diagnosing why it won't execute isn't exactly "brain surgery" for a trained system administrator.

    If you can't make progress, feel free to send access details to your server using this secure form:
    I'll diagnose and/or fix the problem.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Nov 2011
    Posts
    4

    Default Re: Error=Filter "encode" failed (status 126)

    Thanks. I've sent you my information via your secure form. I'm anxious to hear what you find.

  4. #4
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Error=Filter "encode" failed (status 126)

    Hi,

    Thanks, we've received the access details and will begin our investigation shortly.

    I'll post back with the results.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  5. #5
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Error=Filter "encode" failed (status 126)

    Hi,

    I've just noticed that you're using iPage.

    We had a customer last week who was not able to get FormMailEncoder to operate on their iPage server.

    iPage "support" didn't have a clue. We tried very hard, but were not able to get the software to execute on the server.

    I think you'll need to switch to a different hosting provider if you want to use FormMailEncoder.

    The only other option we can give you is that you operate FormMailEncoder from our server as an interim measure, until you switch hosting providers.

    Sorry, we can't workaround servers that are completely disabled from normal behavior.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  6. #6
    Join Date
    Nov 2011
    Posts
    4

    Default Re: Error=Filter "encode" failed (status 126)

    I'll change my hosting to web.com where I have my other sites (one of which successfully uses your software). I'm glad to know it wasn't anything I did wrong at least. I was racking my brains trying to figure out a solution.

    Thanks for trying.

  7. #7
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Error=Filter "encode" failed (status 126)

    Hi,

    We've written to iPage about the problem and they actually replied!

    They've asked for some additional information, which we've provided.

    Hopefully, they'll sort out the problem. If we make progress, I'll post back with an update.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  8. #8
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Error=Filter "encode" failed (status 126)

    Hi,

    iPage have replied again and won't allow installation of FormMailEncoder on their servers.

    Sorry, you'll need to use another webs host.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  9. #9
    Join Date
    Nov 2011
    Posts
    4

    Default Re: Error=Filter "encode" failed (status 126)

    Problem solved with my new web host. So much for trying to save money on hosting!

  10. #10
    Join Date
    Oct 2012
    Location
    Hà Nội
    Posts
    1

    Default Re: Error=Filter "encode" failed (status 126)

    Hi! Thank for your help!
    I made the same error. I fixed it! Thanks again!
    ________________________________________________________________

    Website Desgin Company TruongPhat

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Filter encode failed (status 1)
    By smaynar in forum FormMailEncoder/Decoder
    Replies: 6
    Last Post: 31-Aug-2009, 08:00 PM
  2. Filter encode failed
    By smaynar in forum Community Support
    Replies: 2
    Last Post: 27-Apr-2009, 07:43 PM
  3. Error=Filter "encode" failed (status 135)
    By basic612 in forum FormMailEncoder/Decoder
    Replies: 2
    Last Post: 22-Aug-2008, 06:39 AM
  4. Filter 'Encode' Failed (Status 255)
    By sam in forum FormMailEncoder/Decoder
    Replies: 2
    Last Post: 27-May-2008, 01:20 AM
  5. Error=Cannot execute filter "encode"
    By UKFlyer in forum FormMailEncoder/Decoder
    Replies: 9
    Last Post: 18-Feb-2008, 08:14 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •