Results 1 to 9 of 9

Thread: reCaptcha used to work ~ Now it doesn’t ~ How to fix?

  1. #1
    Join Date
    Aug 2011
    Posts
    16

    Default reCaptcha used to work ~ Now it doesn’t ~ How to fix?



    Hi all –

    I had FormMail and reCaptcha working perfectly for months on a number of forms on several different websites we plan to launch in January.

    The last time we checked them was maybe 2 months ago, and everything from simple contact forms to 40-some field classified ad order forms worked flawlessly using global reCaptcha keys.

    We enthusiastically recommended FormMail to several associates (and we still do.)

    Today, in testing the forms again in anticipation of some early customers, we found that reCaptcha no longer works on any of them so the forms don't work at all.

    With correct challenge words entered, we get “reCaptcha verification failed ()”

    We set up a plain test page without reCaptcha and the form itself works fine, even with the inclusion of formval.js.

    fmbadhandler and our good and bad templates also work as they should.

    When we add the reCaptcha HTML to the form (and obviously properly configure the private key in formmail.php as well as $REQUIRE_CAPTCHA and derive_fields set as imgverify=recaptcha_response_field) everything looks great, but upon properly filling out the form and Captcha words, we get failure report when we submit the form.

    Has anyone else had this issue?

    Our host, Go Daddy, checked on their end and nothing is being blocked there.

    We downloaded and installed a fresh copy of recaptchalib.php, from Google Labs and even tried using new keys, to no avail.

    So, we have a working form that fails when reCaptcha is added even with the right HTML, and new recaptchalib.php and keys.

    There isn’t much to adding reCaptcha to an otherwise working form, so I am stumped as to what is going wrong!

    Here is the test form I set up:

    http://thecorvettelist.com/corvette-...ette-test.html

    Obviously reCaptcha is connection to Google, or the challenge wouldn’t appear. So something is going sideways in the processing of the form, but what?

    When you enter the correct words do you get the failure, too?

    Thanks for any assistance – if I can’t fix this I have to use a different process entirely! But I love this program and want to stay with it! Help!

    Russ . . .


  2. #2
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?

    i can't see anything wrong with it.

    set ALERT_ON_USER_ERROR to true in formmail, and make sure u are receiving alerts

    try ur test form and see if u get an alert with more details.

  3. #3
    Join Date
    Aug 2011
    Posts
    16

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?



    Hi Crabtree –

    Sincere thanks for your input!

    Yes, I have ALERT_ON_USER_ERROR set to true and I am receiving alerts.

    In fact, I do get all the data entered into the form fields, so that proves the form itself works, and that Go Daddy is allowing the script to run and is properly sending the results through its email servers.

    The problem is that when reCaptcha is included in teh HTML per the instructions here (as opposed to reCaptcha’s own instructions) the failure to recognize the correct entry of the challenge words happens.

    Note that I made absolutely no changes to anything – not to the forms, the HTML, the php files, my hosting account – nothing. All is exactly as it was for months, when everything worked.

    Now, with absolutely nothing changed on my end, reCaptcha has started returning errors and none of my several forms on several websites works.

    I did receive 3 alerts overnight, I presume from you testing the form.

    Following is the relevant part of what was returned on the first 2 from “x y”:

    The 3rd email report contained the following:

    Subject: FormMail alert
    To: alert@thecorvettelist.com
    From: FormMail@thecorvettelist.com

    This is a test alert message
    Loaded language is English (builtin)
    PHP version is 5.2.14
    FormMail version is 8.29
    Server type: non-Windows

    DOCUMENT_ROOT: /var/chroot/home/content/g/e/n/generalneo/html
    SCRIPT_FILENAME: /var/chroot/home/content/g/e/n/generalneo/html/thecorvettelist-com/corvette-test/formmail.php
    PATH_TRANSLATED: -not set-
    REAL_DOCUMENT_ROOT: /var/chroot/home/content/g/e/n/generalneo/html/thecorvettelist-com/corvette-test

    SERVER_NAME was thecorvettelist.com
    REQUEST_URI was /corvette-test/formmail.php?testalert=1


    I am not smart enough to interpret these, except to believe that “most” everything is working as it should, except how well FormMail and reCaptcha are playing together.

    They used to get along perfectly – what came between them?

    Again, sincere thanks for your input.

    Russ . . .


  4. #4
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?

    so, there's no additional information in the error alert....

    it kind of sounds like GD has blocked outgoing web requests from the server

    i guess if u can prove that, then GD would have to fix it.

    maybe time to buy some support from tectite

  5. #5
    Join Date
    Aug 2011
    Posts
    16

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?



    Hi Crabtree –

    Thanks again for your continued input.

    I am almost certain this is not a Tectite FormMail problem, since I made absolutely zero changes to any of the instances of FM I am using, nor have I made any changes to the associated HTML.

    So it must be something external to those, and only Google (reCAPTCHA) and Go Daddy are included in that universe.

    (Comcast, my ISP, and anything local to me – my router, firewalls, malware protection, and so on, can also be excluded as a source, since the same error is found by those testing from completely different systems.)

    Since reCAPTCHA works on other sites where it is implemented, I gotta think Google hasn’t changed anything there. If they did, and broke reCAPTCHA while doing so, it would be Headline News. And I have enough faith in Google that any change they did make, say, to their reCAPTCHA servers, would be seamless and not cause prior installs to suddenly fail.

    That leaves Go Daddy as the likely culprit, as you suggested.

    The two times I spoke with them about this they ran some tests and swear it isn’t them. I need to try again and hopefully get someone with a better understanding of how this works. GD is known to make running changes that break things.

    In the interim, I have configured the test form mentioned above to use reverse captcha, and it works 100% as it should.

    Perhaps I should start another thread addressing my questions and comments on it, as well as the tricks I used to set it up.

    Some of those questions include how do screen readers handle the fields hidden by CSS? Aren’t they still visible to screen readers? Should there be a note advising not to fill out that field?

    And won’t reasonably smart spambots look for the obvious signature of a pair (or more) of honeypots such as this?

    My biggest concern, as a marketing guy, is that the absence of a good looking, professional grade CAPTCHA, such as reCAPTCHA, makes the site look cheap or amateurish. Many demographics associate seeing that reCAPTCHA box with a “big time” website which has somehow qualified to be in the big leagues and thus eligible for that industrial grade CAPTCHA. Consequently, I hate not having it. My forms look naked without it.

    I’ll try GD once again and report what I’ve found.

    Thanks again…

    Russ . . .


  6. #6
    Join Date
    Aug 2011
    Posts
    16

    Default UPDATE: reCAPTCHA Now Working!



    UPDATE: reCAPTCHA Now Working!


    Hi Crabtree, All –

    My forms using FM with reCAPTCHA installed are now suddenly working again, with no changes made on my end.

    Therefore, it had to be an issue on Go Daddy’s end which they fixed, deliberately or not.

    As mentioned earlier, there are several players in this:

    FormMail (the php files)

    The HTML of the form itself

    reCAPTCHA
    The reCAPTCHA HTML in the form
    The reCAPTCHA php file
    The Google reCAPTCHA server’s processing

    Go Daddy script processing


    I have no control or access to either Google’s or Go Daddy’s script processing, but since nothing else changed in the items I do control, the sudden failure of reCAPTCHA had to be at either Google or Go Daddy.

    Odds are that it was not an issue at Google. But GD does have a track record of regularly having configuration issues on its shared hosting servers, one of which is where my websites are hosted.

    So it stands to reason that this has been a GD issue, despite their denial the few times I spoke with them about this.

    This morning (Miami time) all of the forms are working properly as they have been for several months, and they weren’t last night.

    The clue was in Filezilla.

    I have been testing another method to curtail form spam which required repeated uploads to the test website, and I use Filezilla for the FTP transfers.

    I have used Filezilla for years and I have a sense of how it works, its rhythm, and so on.

    About the same time reCAPTCHA stopped working, I noticed Filezilla, using the same login settings it always had, was now failing on its first attempt but logged in successfully on the second attempt, a few seconds later. I chalked this up to a new, more secure firewall we recently installed and never made the connection with the also failing reCAPTCHA.

    This morning Filezilla surprisingly logged in immediately on the first attempt, and with no configuration changes locally to our firewall.

    Somehow I put 2 and 2 together (well, 1 and 1) and tried our forms – they all worked!

    Again, I did nothing between the time when they were not working and now, when they are.

    So I gotta think it was something on GD’s end, don’t you?

    Even though GD seems to have fixed it, whatever it was, I don’t see this as good news.

    This is a major point of potential failure for my business and it is totally out of my control.

    Luckily I have spent the last several days learning all I could about form spam curtailment using CAPTCHA, Reverse CAPTCHA, and other methods, and have come to the conclusion that CAPTCHA (reCAPTCHA and other CAPTCHAs) is hardly the best way to go.

    Not only is it annoying to users and has a negative impact on the number of responses you’ll get (as many folks will bail at some point rather than wrestle with a CAPTCHA) but since proper function includes a 3rd party player over which you have no control, your whole system is at risk and at the mercy of that 3rd party - GD in my case.

    Of course, any website, and really, any business, is at the mercy of all kinds of factors beyond our control, but this one can be avoided.

    I am convinced Reverse CAPTCHA is the way to go, and happily FM can accommodate that 100%.

    I’ve written more on this in another thread in the How To section of this Forum, called “Reverse CAPTCHA ~ Thoughts, Tips, and Questions.”

    The bottom line here: My forms were not working for several days because Go Daddy was not properly processing the reCAPTCHA scripts, but suddenly they are working again.

    I hope this info is helpful to anyone else with similar problems, and helps in deciding whether to use a CAPTCHA at all.

    Later…

    Russ . . .


  7. #7
    Join Date
    Mar 2004
    Posts
    2,224

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?

    thx for the update

    and helps in deciding whether to use a CAPTCHA at all.
    or GoDaddy!

  8. #8
    Join Date
    Jul 2011
    Posts
    45

    Default Re: reCaptcha used to work ~ Now it doesn’t ~ How to fix?

    I concur with crabtree.

    I have heard quite a bit about GoDaddy in various forums (or fora for the pedants!) and almost without exception everything I have heard tells me to avoid touching them with a bargepole - even a 25-metre, plastic, sterilised, self-cleaning, earthed and insulated bargepole.

  9. #9
    Join Date
    Aug 2011
    Posts
    16

    Default Go Daddy Update



    Hello –

    Further Update:

    To recap, my implementation of reCAPTCHA on FM on my various forms on websites hosted at Go Daddy had been working for some time, then suddenly stopped working, then about a week later started working again, all without any change to my forms, html, or php files.

    I concluded it must be something on GD’s end, I contacted them, and after some checking they told me it was nothing on their end.

    Finding no solution, I started switching my forms to Reverse CAPTCHA after some research.

    Since the forms were working again I wasn’t as pressed to reconfigure all the forms, so I left many of them as they were.

    I had also noticed a correlation between whether the reCAPTCHA was working or not, and whether Filezilla was able to connect on the first try or not.

    Yesterday Filezilla took two tries to login again, for the first time in a week. I immediately tried a form I hadn’t reconfigured yet and sure enough, reCAPTCHA failed again.

    I immediately called GD again and was more insistent they find a cure. The case was escalated to a “Hosting Specialist” or some such who immediately recognized what was going on when he heard that Filezilla was taking two tries to get in.

    This is my understanding of what he was trying to tell me:

    My hosting account is on a shared Linux server, along with hundreds (maybe thousands) of other websites, all of which share the same ip.

    For security they have a “filter” (his words) that is applied from time to time on different accounts (presumably at random) to insure all those sites get a fair amount of bandwidth.

    When that filter is on it stops certain access attempts. It presumes legit attempts will try a second time and bogus attempts will not. That is why Filezilla is successful on the second attempt, which by default it is programmed to do a few seconds after the first attempt fails.

    Again, hearing that caused the tech to recognize what was going on.

    However, Google only tries once to validate the reCAPTCHA submission. Since the first (and only) attempt fails, Google returns a validation failure and that is why (according to GD) I was having the issue.

    The intermittent failures are due to that filter being applied or not.

    Their solution was for me to do one or both of the following:

    1. Buy a static IP for my account at $5.99 a month. Accounts with “fixed” ip address are not subject to filtering, since it is unlikely I would try to harm my own account and wouldn’t need filtering protection from myself.

    2. Have my account migrated to their new 4GH (Fourth Generation Hosting) service at no cost. There are some things 4GH doesn’t do that their old shared hosting did do, but it is far more robust and scalable. And the likelihood of suffering that filtering thing is somewhat less.

    I chose 2 for now, and will consider a static IP, or upgrading to the next level of hosting which includes a static IP, if I still have this problem. This, presuming I stay with GD.

    Now, I am not a hosting expert, so I have no idea if their story is valid or BS. Since migrating to 4GG, however, Filezilla logs in on the first attempt and reCAPTCHA works. That could change tomorrow.

    I am not necessarily a big fan of GD. I do seem to get the most bang for the buck there, and their support is US based and there is almost never a wait when I call. I have had very few issues over the years and all questions have been adequately answered on the first call.

    Their website is a nightmare and you can’t buy anything without navigating through screens and screens of upsells, most of which are not necessary.

    But I have no loyalty to GD and if a better deal came along making it worth my time to move a couple dozen websites and domain names, I wouldn’t hesitate. But unlimited hosting for unlimited domains for usually under $6 USD a month is hard to beat. Their 4GH hosting, if in reality is even close to their hype, is about as state of the art as shared hosting can be. My sites were fast before, but feel even faster now after migrating to 4GH.

    My point here, in hopes that it might help someone else, is that I have now confirmed the reCAPTCHA failure was 100% on Go Daddy’s end, and had nothing to do with FormMail or reCAPTCHA.

    To implement reCAPTCHA, follow the instructions *exactly* as given on the Tectite site. It does work – flawlessly. If it doesn’t work, call your webhost.

    Good luck…

    Russ . . .


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yet another no_recipients how do I fix this problem
    By unpuertomex in forum Community Support
    Replies: 10
    Last Post: 23-Aug-2011, 04:47 AM
  2. reCaptcha doesn't work
    By mattbtay in forum Community Support
    Replies: 2
    Last Post: 21-Jan-2011, 04:30 PM
  3. How do I fix this error exactly I have tried everything!
    By ComputerGuy523 in forum Community Support
    Replies: 5
    Last Post: 04-Jan-2011, 09:58 PM
  4. reCaptcha allows all submissions, this fix worked for me...
    By raybman in forum Community Support
    Replies: 2
    Last Post: 13-Oct-2010, 06:35 AM
  5. Hopefully a simple fix
    By mominsky in forum HOWTO Guides and Tips
    Replies: 2
    Last Post: 27-May-2008, 12:34 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •