Results 1 to 3 of 3

Thread: Page Redirects, does not send email

  1. #1
    Join Date
    Jan 2013
    Posts
    2

    Default Page Redirects, does not send email

    Hello,

    I have the Formmail working, if I do not redirect to any page and use the default page that Formmail serves up.

    I need to be able to re-direct back to the originating page, and display a link after submission. I have this piece working, but then the email does not come through.

    Here are some of the lines of the code:

    ***********************************************************************************************************
    Invoking Formmail upon submit:

    <!-- STEP 1: Put the full URL to formmail.php on your website in the 'action' value. -->
    <form method="post" action="http://www.MYDOMAIN.com/formmail.php" name="SampleForm">
    <input type="hidden" name="env_report" value="REMOTE_HOST,REMOTE_ADDR,HTTP_USER_AGENT,AUTH_TYPE,REMOTE_USER" />

    ***********************************************************************************************************
    Redirection within the <form> </form> tags:

    <input type="hidden" name="good_url" value="http://www.MYDOMAIN.com/cdp_zix" />

    ***********************************************************************************************************

    If I take out the good_url line, it works and sends the email, but doesn't re-direct. Add it in, and it redirects and displays my link, but doesn't send the email.

    Any help would be much appreciated.

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Page Redirects, does not send email

    Hi,

    It sounds like you might have invalid HTML code.

    Try validating it at http://validator.w3.org/
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Jan 2013
    Posts
    2

    Cool Re: Page Redirects, does not send email

    I was in the middle of updating this post, when I got some support calls and forgot about it.

    I got it to work. My guess is that the form wrapped inside of another form tag was the issue, because that is when it would stop working.

    I changed it to use a php evaluator instead, in the <head>/<head> tags like this:
    <?PHP $sent=$_GET['sent']; ?>

    and changed my good url to be:
    <input type="hidden" name="good_url" value="http://MYURL/cdp_zix.php?sent=sent" />

    And then uses this code, under the submit button, when the good_url comes back:
    <?PHP
    if (isset($sent)) {echo "<p><h3>Thank you for your interested in Zixmail. <br>Click the link to download your 30 day trial of Zixmail: <a href=http://Downloadlink>Zixmail Trial</a></h3></p>";}
    ?>

    and it is all working now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 27-Jun-2011, 04:09 PM
  2. Multible redirects
    By Cardswin69 in forum Community Support
    Replies: 4
    Last Post: 08-Dec-2009, 03:10 AM
  3. Errors as alerts not URL redirects
    By lineofire in forum HOWTO Guides and Tips
    Replies: 1
    Last Post: 06-Aug-2008, 06:53 AM
  4. Using form to send page to a friend.
    By asamarketing in forum Community Support
    Replies: 2
    Last Post: 01-May-2008, 06:22 PM
  5. Redirects, Sessions and Yahoo
    By Froduss in forum FormMail Subscription Support
    Replies: 1
    Last Post: 07-Jul-2004, 09:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •