Results 1 to 8 of 8

Thread: Problem with recipients

  1. #1
    Join Date
    May 2013
    Posts
    9

    Default Problem with recipients

    I have set up the formMail script and it is generally working except that it won't send to a second email address.

    In formMail:
    $TARGET_EMAIL = array("^mike@integrawebdesign\.co\.uk$","^lnp@integrawebdesign\.co\.uk$");

    In the form:
    <input name="recipients" type="hidden" value="mike@integrawebdesign.co.uk,lnp@integrawebdesign.co.uk" />

    Error message:

    The following error occurred in FormMail : Invalid email addresses were specified in the form : recipients: lnp(at)integrawebdesign(dot)co(dot)uk

    Can anyone advise what is wrong?

    Mike

  2. #2
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Problem with recipients

    Hi,

    Can you post a link to the form?

    ginger

  3. #3
    Join Date
    May 2013
    Posts
    9

  4. #4
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Problem with recipients

    You actually have this in the form which isn't correct:

    lnp(at)integrawebdesign(dot)co(dot)uk


    ginger

  5. #5
    Join Date
    May 2013
    Posts
    9

    Default Re: Problem with recipients

    Thanks for pointing that out. I hadn't checked the page source as displayed. The form in the CMS editing interface has the correct syntax, lnp@integrawebdesign.co.uk, but it appears the CMS modifies this to replace the @ and . characters. But it doesn't do it for the other email address in the form. I don't understand why this is happening. I would have expected the form to be submitted with the address as entered not as displayed.

    I will have to check out the CMS software.

  6. #6
    Join Date
    May 2013
    Posts
    9

    Default Re: Problem with recipients

    I have now tried using two separate recipients inputs with one email address in each, which seems to only send to one email address. It appears that I cannot include two email addresses as recipients but I cannot work out why. Perhaps I will just have accept this and work with it.

    Mike

  7. #7
    Join Date
    May 2008
    Posts
    1,291

    Default Re: Problem with recipients

    Yeah, I don't know why the CMS would do that, but I do know that I've used multiple recipients before and not had a problem.

    Maybe Google the problem and specify the name of the CMS. Maybe someone else has had the same problem.

    ginger

  8. #8
    Join Date
    May 2013
    Posts
    9

    Default Re: Problem with recipients

    It was the CMS. There was an option to filter frontend email addresses which did it. I have changed the option and it now works with two email addresses in the one recipients input.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yes yet another no valid recipients problem
    By axlefoley in forum Community Support
    Replies: 3
    Last Post: 06-Sep-2011, 10:50 PM
  2. File Upload/No recipients problem
    By Rella in forum FormMail Subscription Support
    Replies: 10
    Last Post: 01-Sep-2005, 09:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •