Results 1 to 6 of 6

Thread: Formmail works fine on additional domains but primary domain stopped/Windows server

  1. #1
    Join Date
    May 2007
    Posts
    52

    Unhappy Formmail works fine on additional domains but primary domain stopped/Windows server

    Hi,

    I guess this is a server issue so I need to know what to tell my techs to do. I'm a hosting reseller and my service domain is on a Windows server. Tectite mail forms are working with my addtional domains on the same server, but recently the form on the service domain stopped working. I tried it with and without:
    1. php.ini file
    2. pear in the php file

    Also experimented with sendmail and other options in the php file. Nothing works. "An error occurred while processing the form . Please contact us directly since this form is not working."

    I did notice that the service domain's mail server address is different from the additional domains (mail6 instead of mail), so I corrrected that in the pear and the ini files.

    testmail.php: Mail function succeeded
    testmail2.php: Mail function succeeded with -f parameter

    Tried sendmail f true and false; neither worked.

    Contact form:
    http://sheerwebhost.com/30h6x91md.htm

    Thanks for your help.
    Reesa Marchetti, President
    Sheer Web Host, http://sheerwebhost.com
    Sheer Web Design, http://sheerwebdesign.com
    (856) 881-6000 USA

  2. #2
    Join Date
    May 2007
    Posts
    52

    Red face Re: Formmail works fine on additional domains but primary domain stopped/Windows ser

    Damn, I just fixed it myself!

    Taking a hint from a previous post, I changed SENDMAIL_F_OPTION, SENDMAIL_F_OPTION_LINE and SET_SENDER_FROM_EMAIL to true.

    All's well that ends well.
    Reesa Marchetti, President
    Sheer Web Host, http://sheerwebhost.com
    Sheer Web Design, http://sheerwebdesign.com
    (856) 881-6000 USA

  3. #3
    Join Date
    Dec 2003
    Posts
    3,980

    Talking Re: Formmail works fine on additional domains but primary domain stopped/Windows ser

    Hi,

    I'm glad it's sorted out.

    However, let me know if you have any other issues you need me to look into.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  4. #4
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Formmail works fine on additional domains but primary domain stopped/Windows ser

    BTW, the document that takes you through all the steps for resolving email problems is here: http://www.tectite.com/fmdoc/emailproblems.php
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  5. #5
    Join Date
    May 2007
    Posts
    52

    Talking Re: Formmail works fine on additional domains but primary domain stopped/Windows ser

    Hi Russell,

    Thanks for all your help. Yes, I have used that document many times.

    Since you asked, can you point me to more info on MANGLE and the best way to create/change mangled addresses?
    Reesa Marchetti, President
    Sheer Web Host, http://sheerwebhost.com
    Sheer Web Design, http://sheerwebdesign.com
    (856) 881-6000 USA

  6. #6
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Formmail works fine on additional domains but primary domain stopped/Windows ser

    Hi,

    Here it is: http://www.tectite.com/fmdoc/at_mangle.php

    However, for full email address security, we recommend you use an INI file: http://www.tectite.com/fmhowto/inifile.php

    Inside FormMail's configuration section is the URL for each setting's documentation, just above it.

    Also, you can use the search box on our website to find any setting.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Formail works fine... but '?testalert=1' doesn't
    By Visualeyes in forum Community Support
    Replies: 3
    Last Post: 06-May-2010, 08:21 PM
  2. Windows - Formmail only works with code added at top
    By djdevine in forum Community Support
    Replies: 1
    Last Post: 02-Oct-2009, 05:32 PM
  3. Formmail works fine but only message field shows up for results
    By jennypretty in forum Community Support
    Replies: 2
    Last Post: 13-May-2007, 07:22 PM
  4. Formmail works fine, but
    By maropa in forum Community Support
    Replies: 12
    Last Post: 09-May-2007, 06:12 AM
  5. Formmail works fine, but no e-mail
    By Wiggy in forum FormMail Subscription Support
    Replies: 1
    Last Post: 08-Jan-2004, 04:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •