Results 1 to 4 of 4

Thread: Form sends email, but redirects to /cgi-sys/FormMail.cgi

  1. #1
    Join Date
    Mar 2014
    Posts
    3

    Default Form sends email, but redirects to /cgi-sys/FormMail.cgi

    My Tectite form has been working fine for over two years. Suddenly today, the Submit button sends me the email great, but the visitor is redirected to the FormMail.cgi page. The "Form Submission Results" are displayed - including the intended redirect page. What happened? There are 50+ forms built into this site, and they're all doing it. Yet the forms on my other domains, on the same server, are working fine. Is this a hosting problem, or has my php file maybe been hacked? Example page: http://www.wehireheroes.us/Buffalo/jobpost-premium.html (only the first 3 fields are required). Please assist - thanks!
    ~LTW
    Last edited by skyvaultgroup; 28-Mar-2014 at 04:48 AM.

  2. #2
    Join Date
    Dec 2003
    Posts
    3,980

    Default Re: Form sends email, but redirects to /cgi-sys/FormMail.cgi

    Hi,

    We have no access to your server and cannot take any action at all regarding your forms.

    If things have changed on your server, then either someone you authorized made these changes, or your hosting provider has done something without telling you.

    I recommend contacting your hosting provider for information.

    Also, if you have backups of your site, then you can compare what's on your server with your backup, or restore from backup.

    Please note, however, we do offer a Hosted FormMail service so that you can avoid all issues with hosting providers changing or breaking things without your knowledge. You may want to consider this once you figure out what happened.

    I hope that helps.
    Russell Robinson - Author of Tectite FormMail and FormMailDecoder
    http://www.tectite.com/

  3. #3
    Join Date
    Mar 2014
    Posts
    3

    Cool Re: Form sends email, but redirects to /cgi-sys/FormMail.cgi

    Hey Russell,
    Thanks for responding - that's more than my host has done. So far all I'm getting is "we don't know, it's not fixable at this level, it's been referred to a server admin who is currently off the clock". Maddening, to say the least. That hosted FormMail service is looking better by the hour. ~LTW

  4. #4
    Join Date
    Mar 2014
    Posts
    3

    Cool Re: Form sends email, but redirects to /cgi-sys/FormMail.cgi

    Problem solved! Seems there was a cpanel update that caused my forms to stop working. I simply needed to have the form call for formmail.pl instead of FormMail.cgi. Such a simple change - thankfully, I found a tech that took the problem seriously and noticed the difference. With 56 active forms on my site, I really needed a simple solution. I was under the impression that PHP was the preferred script these days, but apparently HostGator is still liking Pearl. Curious...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Page Redirects, does not send email
    By completedp in forum Features Questions
    Replies: 2
    Last Post: 16-Jan-2013, 01:35 PM
  2. Form sends without valid email address
    By kadamson in forum Community Support
    Replies: 2
    Last Post: 02-Sep-2010, 03:30 PM
  3. form sends the wrong email
    By Mickyboy in forum Community Support
    Replies: 6
    Last Post: 16-Mar-2010, 04:17 PM
  4. Submitting Form Sends to Multiple Email Addresses
    By benduke in forum Community Support
    Replies: 2
    Last Post: 02-Sep-2009, 10:39 PM
  5. Login Form that redirects to different urls
    By Giraffeweb in forum Community Support
    Replies: 0
    Last Post: 12-Sep-2008, 12:45 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •