Results 1 to 2 of 2

Thread: Works, but not receiving "REQUIRED" or "ENV_REPORT" fields

  1. #1
    Join Date
    Nov 2006
    Posts
    15

    Default Works, but not receiving "REQUIRED" or "ENV_REPORT" fields

    If I do an error test "FormMail script error" return's all the the fields just fine, but when I submit correctly, all that is returned is the data from the comments field (without the "comments:" field label). Help? THX!

    Here is an error result example from a blank submission:


    The following error occurred in FormMail :
    missing_fields
    Error=The form required some values that you did not seem to provide.
    Valid email (required)
    Name (required)


    email:
    realname:


    Comments: ''
    Referring page was http://simplegraphics.org/contact.php
    SERVER_NAME was simplegraphics.org
    REQUEST_URI was /formmail.php


    User IP address was 174.124.45.185

    User agent was Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:28.0) Gecko/20100101 Firefox/28.0




  2. #2
    Join Date
    Nov 2006
    Posts
    15

    Default Re: Works, but not receiving "REQUIRED" or "ENV_REPORT" fields

    SOLVED!
    It's the little things that REALLY matter!

    The form was missing an "=" after value (my editing error)

    Problem line:
    <input type="hidden" name="mail_options" value"AlwaysList,FromLineStyle" />

    Fixed:
    <input type="hidden" name="mail_options" value="AlwaysList,FromLineStyle" />

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Required fields entered, but "DEFAULT" error response
    By bmart in forum Community Support
    Replies: 0
    Last Post: 18-Feb-2011, 11:00 PM
  2. How to do "All fields required"
    By myrrh in forum Community Support
    Replies: 1
    Last Post: 02-Nov-2009, 02:53 PM
  3. False Positive: The fields "zip" and "zip" contained duplicate data [M143]
    By BLynch in forum FormMail Subscription Support
    Replies: 2
    Last Post: 08-Aug-2007, 08:25 PM
  4. Does "alert_to" form field use "AT_MANGLE" feature?
    By jennyp in forum Community Support
    Replies: 4
    Last Post: 05-Dec-2006, 11:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •