Results 1 to 4 of 4

Thread: Cannot send mail with form, but tests OK

  1. #1
    Join Date
    Feb 2006
    Posts
    2

    Default Cannot send mail with form, but tests OK

    I can't seem to figure out why the sampleform.html will NOT send email, yet when I downloaded and installed the two php test files, they both sent mail just fine.

    I've tried sending to three different addresses. I've made sure the recipient is one allowed by the $TARGET_EMAIL config setting. The only other setting I made in the config was the document root (htdocs), but if it gets it from the same place phpinfo does, it was already going to be correct.

    One odd thing that may or may not affect it, is that my server is currently NOT known by a domain name, just IP address. That's because I'm in the process of moving everything from its current location to the new server, and haven't changed the DNS yet. But, I'm not trying to send mail to that server, so it shouldn't be a problem. Also, I've got squirrelmail installed on this new server, and it will send mail fine.

    Any ideas? What more information can I provide?

    Thanks!

  2. #2
    Join Date
    Jul 2005
    Posts
    175

    Default Re: Cannot send mail with form, but tests OK

    first, normally you don't have to SET_REAL_DOCUMENT_ROOT to get the script working
    (quotation formmail.php: "... If you're not using the "filter" feature in your forms, you don't need to worry about these settings.")

    are you sure that you have "quoted" your email address correctly at the TARGET_EMAIL feature in formmail.php with all the ^, \, $ and "

    if it's a dedicated IP address i think it shouldn't affect it

  3. #3
    Join Date
    Feb 2006
    Posts
    2

    Default Re: Cannot send mail with form, but tests OK

    Thanks for the reply.

    The SET_REAL_DOCUMENT_ROOT setting doesn't seem to affect it either way. I've tried both.

    The $TARGET_EMAIL value is properly quoted as "^me@mydomain\.com$"

    I think it has to do with my temporary "no domain name" issue. I'm not sure I can explain it easily, but I'll try.

    1. I already have foo.com registered, running on another hosting service. I've decided to start a virtual private server instead.

    2. The server settings have been told that it will be "foo.com", but no DNS changes have been made yet. i.e., I'm still using my existing foo.com like I always have, while I set this up.

    3. On my new server, I've created one account "me".

    4. If I send php mail via the form to "me@foo.com", it arrives on my new server, I guess because it internally realizes that it's already here and doesn't need to go outside the system.

    5. If I send php mail via the form to me@somewhereelse.com", it bounces, saying "server.foo.com" is not valid.

    6. If I send mail from another system, to me@foo.com, it arrives at my old server, because that's where the world's DNS's are pointing.

    So maybe all this is because I haven't changed the DNS yet.

    Sorry if I'm being stupid. This is all new to me. I just want to get everything running before I change the DNS, because "foo.com" is a commercial site that I can't afford to have down any longer than necessary.

    Thanks

  4. #4
    Join Date
    Jul 2005
    Posts
    175

    Default Re: Cannot send mail with form, but tests OK

    Hi,

    No problem.
    Yep, your description sounds somehow plausible.
    By the way I am not sure if I would have been figuring out this in your case.

    Best, Erik

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Converting Underscores to Spaces from Form to E-mail
    By Kirk in forum FormMail Subscription Support
    Replies: 1
    Last Post: 01-Dec-2004, 06:20 AM
  2. Creating mail object using Mail::factory ("smtp", ....) and FormMail
    By stingray in forum FormMail Subscription Support
    Replies: 1
    Last Post: 13-Jul-2004, 09:27 PM
  3. Does your web server send mail?
    By russellr in forum FormMail Subscription Support
    Replies: 0
    Last Post: 10-Feb-2004, 08:19 AM
  4. Help trying to set up a form to email and send info to file
    By rridsdale in forum FormMail Subscription Support
    Replies: 1
    Last Post: 14-Jan-2004, 02:38 AM
  5. Form Mail Questions
    By Ramius in forum FormMail Subscription Support
    Replies: 5
    Last Post: 12-Jan-2004, 03:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •